]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/default.nix
Add a kanboard farm
[perso/Immae/Config/Nix.git] / modules / private / websites / default.nix
index 7aac7b879d72b08e8969ba97e25a8a8f45c2b194..440fddf512ea8ac0d8f6f49122b274f00d4bc878 100644 (file)
@@ -154,7 +154,7 @@ in
       httpdName = "Prod";
       ips =
         let ips = config.myEnv.servers.eldiron.ips.production;
-        in [ips.ip4] ++ (ips.ip6 or []);
+        in (ips.ip4 or []) ++ (ips.ip6 or []);
       modules = makeModules;
       extraConfig = makeExtraConfig;
       fallbackVhost = {
@@ -171,11 +171,11 @@ in
       httpdName = "Inte";
       ips =
         let ips = config.myEnv.servers.eldiron.ips.integration;
-        in [ips.ip4] ++ (ips.ip6 or []);
+        in (ips.ip4 or []) ++ (ips.ip6 or []);
       modules = makeModules;
       extraConfig = makeExtraConfig ++ moomin;
       fallbackVhost = {
-        certName    = "eldiron";
+        certName    = "integration";
         hosts       = ["eldiron.immae.eu" ];
         root        = www_root;
         extraConfig = [ "DirectoryIndex index.htm" ];
@@ -188,7 +188,7 @@ in
       httpdName = "Tools";
       ips =
         let ips = config.myEnv.servers.eldiron.ips.main;
-        in [ips.ip4] ++ (ips.ip6 or []);
+        in (ips.ip4 or []) ++ (ips.ip6 or []);
       modules = makeModules;
       extraConfig = makeExtraConfig ++
         [ ''
@@ -212,15 +212,22 @@ in
       };
     };
 
+    myServices.tools.kanboard.farm.instances.tonnelle = null;
     myServices.websites = {
       bakeer.cloud.enable = true;
       capitaines.landing_pages.enable = true;
 
       chloe = {
-        integration.enable = true;
+        new.enable = true;
         production.enable = true;
       };
 
+      christophe_carpentier = {
+        website.enable = true;
+        agorakit.enable = true;
+        agora-project.enable = true;
+      };
+
       cip-ca = {
         sympa.enable = true;
       };
@@ -266,6 +273,13 @@ in
 
       leila.production.enable = true;
 
+      librezo = {
+        cloud.enable = true;
+        dolibarr.enable = true;
+        dolibarrDev.enable = true;
+        website.enable = true;
+      };
+
       ludivine = {
         integration.enable = true;
         production.enable = true;
@@ -275,12 +289,21 @@ in
 
       nath.villon.enable = true;
 
+      nicecoop = {
+        gestion-compte.enable = true;
+        gestion-compte-integration.enable = true;
+        odoo.enable = true;
+        copanier.enable = true;
+      };
       papa = {
         surveillance.enable = true;
         maison_bbc.enable = true;
       };
 
-      patrick_fodella.production.enable = true;
+      patrick_fodella = {
+        ecolyeu.enable = true;
+        altermondia.enable = true;
+      };
 
       piedsjaloux = {
         integration.enable = true;
@@ -313,6 +336,7 @@ in
       tools.tools.enable = true;
       tools.email.enable = true;
       tools.stats.enable = false;
+      tools.visio.enable = true;
 
       games.codenames.enable = true;
       games.terraforming-mars.enable = true;