]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/connexionswing/production.nix
Rework integration websites
[perso/Immae/Config/Nix.git] / modules / private / websites / connexionswing / production.nix
index 4b0407f4959ab64201b016f80feeba8b5b6e027c..8d16de644369cf25d13d2bedb28daab6e1f20abe 100644 (file)
@@ -1,36 +1,32 @@
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.connexionswing.production;
-  app = pkgs.callPackage ./app {
-    composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
-    environment = secrets.environment;
-    varDir = "/var/lib/connexionswing_production";
-    secretsPath = config.secrets.fullPaths."websites/connexionswing/production";
-  };
   cfg = config.myServices.websites.connexionswing.production;
-  pcfg = config.services.phpApplication;
+  ftpRoot = "/var/lib/connexionswing_production";
+  phpRoot = "${ftpRoot}/php";
+  webRoot = "${phpRoot}/web";
+  varDir = "${ftpRoot}/var";
+  sessionDir = "${ftpRoot}/sessions";
+  packagePath = "/var/lib/ftp/release.immae.eu/buildbot/Connexionswing";
+  branch = "master";
 in {
   options.myServices.websites.connexionswing.production.enable = lib.mkEnableOption "enable Connexionswing's website in production";
 
   config = lib.mkIf cfg.enable {
     services.webstats.sites = [ { name = "connexionswing.com"; } ];
-    services.phpApplication.apps.connexionswing_production = {
-      websiteEnv = "production";
-      httpdUser = config.services.httpd.Prod.user;
-      httpdGroup = config.services.httpd.Prod.group;
-      inherit (app) webRoot varDir;
-      varDirPaths = {
-        "medias" = "0700";
-        "uploads" = "0700";
-        "var" = "0700";
-      };
-      inherit app;
-      serviceDeps = [ "mysql.service" ];
-      preStartActions = [
-        "./bin/console --env=${app.environment} cache:clear --no-warmup"
-      ];
-      phpOpenbasedir = [ "/tmp" "/run/wrappers/bin/sendmail" ];
-      phpPool = {
+    services.phpfpm.pools.connexionswing_production = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      settings = {
+        "listen.owner" = config.services.httpd.Prod.user;
+        "listen.group" = config.services.httpd.Prod.group;
+        "php_admin_value[open_basedir]" = builtins.concatStringsSep ":" [
+          ftpRoot
+          config.secrets.fullPaths."websites/connexionswing/production"
+          "/run/wrappers/bin/sendmail"
+          "/tmp"
+        ];
+        "php_admin_value[session.save_path]" = sessionDir;
         "php_admin_value[upload_max_filesize]" = "20M";
         "php_admin_value[post_max_size]" = "20M";
         #"php_admin_flag[log_errors]" = "on";
@@ -40,11 +36,60 @@ in {
         "pm.min_spare_servers" = "1";
         "pm.max_spare_servers" = "3";
       };
-      phpWatchFiles = [
-        config.secrets.fullPaths."websites/connexionswing/production"
-      ];
       phpPackage = pkgs.php72;
     };
+    systemd.services."phpfpm-connexionswing_production" = {
+      after = lib.mkAfter ["mysql.service"];
+      wants = ["mysql.service"];
+      path = lib.mkAfter [ pkgs.gnutar pkgs.gzip pkgs.php72 ];
+      preStart = let
+        script = pkgs.writeScriptBin "connexionswing-production-pre" ''
+          #! ${pkgs.stdenv.shell}
+
+          [ -f ${packagePath}/${branch}.tar.gz ] || exit 1
+
+          cd ${ftpRoot}
+          if ! [ -f .tarball_sum ] || ! sha256sum -c .tarball_sum; then
+            tar -xf ${packagePath}/${branch}.tar.gz --one-top-level=php_new
+            if [ -d php ]; then
+              mv php php_old
+            fi
+            mv php_new php
+          fi
+          cd php
+          rm -rf var/{logs,cache}
+          ln -sf ${varDir}/var/{logs,cache} var/
+          ln -sf ${varDir}/{medias,uploads} web/images/
+          ln -sf ${config.secrets.fullPaths."websites/connexionswing/production"} app/config/parameters.yml
+          SYMFONY_ENV=${secrets.environment} ./bin/console --env=${secrets.environment} cache:clear --no-warmup
+          sha256sum ${packagePath}/${branch}.tar.gz > ${ftpRoot}/.tarball_sum
+        '';
+      in
+        "/run/wrappers/bin/sudo -u ${config.services.httpd.Prod.user} ${script}/bin/connexionswing-production-pre";
+      postStart = let
+        script = pkgs.writeScriptBin "connexionswing-production-post" ''
+          #! ${pkgs.stdenv.shell}
+
+          cd ${ftpRoot}
+          if [ -d php_old ]; then
+            rm -rf php_old
+          fi
+        '';
+      in
+        "/run/wrappers/bin/sudo -u ${config.services.httpd.Prod.user} ${script}/bin/connexionswing-production-post";
+      serviceConfig.TimeoutStartSec="infinity";
+    };
+    services.filesWatcher.phpfpm-connexionswing_production = {
+      restart = true;
+      paths = [ "${packagePath}/${branch}.tar.gz" ];
+    };
+
+    system.activationScripts.connexionswing_production = {
+      deps = ["users"];
+      text = ''
+        install -m 0700 -o ${config.services.httpd.Prod.user} -g ${config.services.httpd.Prod.group} -d ${ftpRoot} ${sessionDir}
+      '';
+    };
 
     secrets.keys."websites/connexionswing/production" = {
       user = config.services.httpd.Prod.user;
@@ -77,20 +122,20 @@ in {
       certName     = "connexionswing";
       certMainHost = "connexionswing.com";
       hosts        = ["connexionswing.com" "sandetludo.com" "www.connexionswing.com" "www.sandetludo.com" ];
-      root         = app.webRoot;
+      root         = webRoot;
       extraConfig  = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.connexionswing_production}|fcgi://localhost"
+          SetHandler "proxy:unix:${config.services.phpfpm.pools.connexionswing_production.socket}|fcgi://localhost"
         </FilesMatch>
 
-        <Directory ${app.varDir}/medias>
+        <Directory ${varDir}/medias>
           Options FollowSymLinks
           AllowOverride None
           Require all granted
         </Directory>
 
-        <Directory ${app.varDir}/uploads>
+        <Directory ${varDir}/uploads>
           Options FollowSymLinks
           AllowOverride None
           Require all granted
@@ -98,7 +143,7 @@ in {
 
         Use Stats connexionswing.com
 
-        <Directory ${app.webRoot}>
+        <Directory ${webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted