]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/chloe/production.nix
Start moving php configuration to a dedicated module
[perso/Immae/Config/Nix.git] / modules / private / websites / chloe / production.nix
index d4b22994d0a98d1c143ea60125253f82904f8323..6e0c34d7d8cb6789361ca10dcf65c78106380871 100644 (file)
@@ -25,10 +25,7 @@ in {
       '';
     };
     system.activationScripts.chloe_prod = chloe.activationScript;
-    system.extraSystemBuilderCmds = ''
-      mkdir -p $out/webapps
-      ln -s ${chloe.app.webRoot} $out/webapps/${chloe.apache.webappName}
-      '';
+    myServices.websites.webappDirs."${chloe.apache.webappName}" = chloe.app.webRoot;
     services.websites.production.modules = chloe.apache.modules;
     services.websites.production.vhostConfs.chloe = {
       certName     = "chloe";
@@ -37,5 +34,8 @@ in {
       root         = chloe.apache.root;
       extraConfig  = [ chloe.apache.vhostConf ];
     };
+    services.websites.production.watchPaths = [
+      "/var/secrets/webapps/${chloe.app.environment}-chloe"
+    ];
   };
 }