]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/tasks/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / tasks / default.nix
index ac2aa2184074baf8f76f60e52820da7076241c9b..087885d837efa8f0522f75348612f7e500475bea 100644 (file)
@@ -86,15 +86,28 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.tasks = {
-      rootDir = "/var/lib";
-      excludeFile = ''
-        + /var/lib/taskserver
-        + /var/lib/taskwarrior-web
-        - /var/lib
-        '';
+    myServices.chatonsProperties.services.taskwarrior = {
+      file.datetime = "2022-08-22T00:00:00";
+      service = {
+        name = "Taskwarrior";
+        description = "Taskwarrior is Free and Open Source Software that manages your TODO list from the command line. Web interface and synchronization server";
+        website = "https://task.immae.eu/";
+        logo = "https://taskwarrior.org/favicon.ico";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["MEMBER" "CLIENT"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Taskwarrior";
+        website = "https://taskwarrior.org/";
+        license.url = "https://github.com/GothenburgBitFactory/taskwarrior/blob/develop/LICENSE";
+        license.name = "MIT License";
+        version = pkgs.webapps.taskwarrior-web.version;
+        source.url = "https://taskwarrior.org/download/";
+      };
     };
-
     secrets.keys = {
       "webapps/tools-taskwarrior-web" = {
         user = "wwwrun";
@@ -165,9 +178,9 @@ in {
       certName    = "eldiron";
       addToCerts  = true;
       hosts       = [ "task.immae.eu" ];
-      root        = "/run/current-system/webapps/_task";
+      root        = ./www;
       extraConfig = [ ''
-        <Directory /run/current-system/webapps/_task>
+        <Directory ${./www}>
           DirectoryIndex index.php
           Use LDAPConnect
           Require ldap-group cn=users,cn=taskwarrior,ou=services,dc=immae,dc=eu
@@ -243,10 +256,8 @@ in {
       };
     };
 
-    services.websites.webappDirs._task = ./www;
-
     security.acme.certs."task" = config.myServices.certificates.certConfig // {
-      inherit user group;
+      inherit group;
       domain = fqdn;
       postRun = ''
         systemctl restart taskserver.service