]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/system/eldiron.nix
Export some directories to pub accounts
[perso/Immae/Config/Nix.git] / modules / private / system / eldiron.nix
index 6ccaea5797f19cde9965856219dd2466811ae726..b2a728c1864fa8173c1fbe955491bc5427fa6376 100644 (file)
@@ -1,10 +1,12 @@
 { privateFiles }:
 { config, pkgs, ... }:
 {
+  boot.supportedFilesystems = [ "zfs" ];
   boot.kernelPackages = pkgs.linuxPackages_latest;
   myEnv = import "${privateFiles}/environment.nix" // { inherit privateFiles; };
 
   networking = {
+    hostId = "8262ca33"; # generated with head -c4 /dev/urandom | od -A none -t x4
     firewall.enable = true;
     # 176.9.151.89 declared in nixops -> infra / tools
     interfaces."eth0".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
     ];
   };
 
+  fileSystems."/var/lib/pub/immae/devtools" = {
+    device = "/run/current-system/sw/bin/bindfs#/var/lib/ftp/devtools.immae.eu/";
+    fsType = "fuse";
+    options = [ "force-user=pub" "create-for-user=wwwrun" "create-for-group=wwwrun" ];
+  };
+  environment.systemPackages = [ pkgs.bindfs ];
+
   # This value determines the NixOS release with which your system is
   # to be compatible, in order to avoid breaking some software such as
   # database servers. You should change this only after NixOS release