]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/ssh/default.nix
Add syden peertube website
[perso/Immae/Config/Nix.git] / modules / private / ssh / default.nix
index d4c1ab3ffac3b8c462b4ca5139d40c8c351555dc..aea3ac0e79d1554b2fe70d6d4d1308d4c12d02e9 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, ... }:
+{ lib, pkgs, config, ... }:
 let
   cfg = config.myServices.ssh;
 in
@@ -56,7 +56,7 @@ in
       user = "nobody";
       group = "nogroup";
       permissions = "0400";
-      text = myconfig.env.sshd.ldap.password;
+      text = config.myEnv.sshd.ldap.password;
     }];
     system.activationScripts.sshd = {
       deps = [ "secrets" ];
@@ -77,12 +77,11 @@ in
         substituteAll ${./ldap_authorized_keys.sh} $out
         chmod a+x $out
         '';
-      ldap_authorized_keys =
-        pkgs.mylibs.wrap {
-          name = "ldap_authorized_keys";
-          file = fullScript;
-          paths = deps;
-        };
+      ldap_authorized_keys = pkgs.runCommand "ldap_authorized_keys" {
+        buildInputs = [ pkgs.makeWrapper ];
+      } ''
+        makeWrapper "${fullScript}" "$out" --prefix PATH : ${lib.makeBinPath deps}
+        '';
     in {
       enable = true;
       mode = "0755";