]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/myplugins.nix
Retry dovecot submission on failure
[perso/Immae/Config/Nix.git] / modules / private / monitoring / myplugins.nix
index 864fa99b1b297ff8c0f93662b2b0de4ea80aecd2..76aa5572f96f5a8011fe00da18dc6b894835d687 100644 (file)
@@ -113,7 +113,7 @@ in
       cp ${./plugins}/check_eriomem $out/
       patchShebangs $out/check_eriomem
       wrapProgram $out/check_eriomem --prefix PATH : ${lib.makeBinPath [
-        pkgs.s3cmd pkgs.python3
+        pkgs.s3cmd pkgs.python38
       ]}
       cp ${./plugins}/check_backup_age $out/check_backup_eriomem_age
       patchShebangs $out/check_backup_eriomem_age
@@ -171,6 +171,8 @@ in
     commands = {
       check_http = "$USER1$/check_http --sni -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
       check_https = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
+      check_https_4 = "$USER1$/check_http -4 --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
+      check_https_6 = "$USER1$/check_http -6 --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
       check_https_auth = "$USER1$/check_http --sni --ssl -a \"$USER202$\" -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -r \"$ARG3$\"";
       check_https_certificate = "$USER1$/check_http --sni --ssl -H \"$ARG1$\" -C 21,15";
       check_https_code = "$USER1$/check_http --sni --ssl -f stickyport -H \"$ARG1$\" -u \"$ARG2$\" -e \"$ARG3$\" -r \"$ARG4$\"";
@@ -233,7 +235,7 @@ in
       cp ${./plugins}/check_mem.sh $out/
       patchShebangs $out/check_mem.sh
       wrapProgram $out/check_mem.sh --prefix PATH : ${lib.makeBinPath [
-        pkgs.gnugrep pkgs.gawk pkgs.procps-ng
+        pkgs.gnugrep pkgs.gawk pkgs.procps
       ]}
     '';
   };
@@ -296,7 +298,7 @@ in
       cp ${./plugins}/check_ovh_sms $out/
       patchShebangs $out/check_ovh_sms
       wrapProgram $out/check_ovh_sms --prefix PATH : ${lib.makeBinPath [
-        (pkgs.python3.withPackages (ps: [ps.ovh]))
+        (pkgs.python38.withPackages (ps: [ps.ovh]))
       ]}
     '';
   };