]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/monitoring/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / monitoring / default.nix
index 2e0773a2e05aa0900deedb717eebbfcfea77a33e..f48e20661e4d19a7070d73990bddbdab6a3bfdb9 100644 (file)
@@ -145,6 +145,28 @@ in
   };
 
   config = lib.mkIf cfg.enable {
+    myServices.chatonsProperties.hostings.monitoring = lib.mkIf cfg.master {
+      file.datetime = "2022-08-27T16:00:00";
+      hosting = {
+        name = "Monitoring";
+        description = "Website and server health monitoring";
+        website = "https://status.immae.eu";
+        logo = "https://www.naemon.io/favicon.ico";
+        status.level = "OK";
+        status.description = "OK";
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "naemon";
+        website = "https://www.naemon.io/";
+        license.url = "https://github.com/naemon/naemon-core/blob/master/COPYING";
+        license.name = "GNU General Public License v2.0";
+        version = config.services.naemon.package.version;
+        source.url = "https://github.com/naemon/naemon-core";
+        modules = "livestatus,status-engine";
+      };
+    };
     services.nginx = lib.mkIf config.myServices.status.enable {
       virtualHosts."status.immae.eu".locations = objectsFiles // {
         "=/common/immae.cfg" = {