]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/mail/postfix.nix
Add sympa mailing-list
[perso/Immae/Config/Nix.git] / modules / private / mail / postfix.nix
index 92fa580d42da6d13f4a6ec30778b5911d4c3f073..46d45c188cbc549f1199897fcc5d670147923ed2 100644 (file)
@@ -18,7 +18,7 @@
           hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
           dbname = ${config.myEnv.mail.postfix.mysql.database}
           query = SELECT DISTINCT destination
-            FROM forwardings_merge
+            FROM forwardings
             WHERE
               ((regex = 1 AND '%s' REGEXP CONCAT('^',source,'$') ) OR (regex = 0 AND source = '%s'))
               AND active = 1
           hosts = unix:${config.myEnv.mail.postfix.mysql.socket}
           dbname = ${config.myEnv.mail.postfix.mysql.database}
           query = SELECT DISTINCT destination
-            FROM forwardings_merge
+            FROM forwardings
             WHERE
-              ((regex = 1 AND '%s' REGEXP CONCAT('^',source,'$') ) OR (regex = 0 AND source = '%s'))
+              (
+                (regex = 1 AND CONCAT(SUBSTRING_INDEX('%u', '+', 1), '@%d') REGEXP CONCAT('^',source,'$') )
+              OR
+                (regex = 0 AND source = CONCAT(SUBSTRING_INDEX('%u', '+', 1), '@%d'))
+              )
               AND active = 1
-            UNION SELECT '%s' AS destination
+            UNION SELECT CONCAT(SUBSTRING_INDEX('%u', '+', 1), '@%d') AS destination
           '';
       }
       {
 
     networking.firewall.allowedTCPPorts = [ 25 465 587 ];
 
-    nixpkgs.overlays = [ (self: super: {
-      postfix = super.postfix.override { withMySQL = true; };
-    }) ];
     users.users."${config.services.postfix.user}".extraGroups = [ "keys" ];
     services.filesWatcher.postfix = {
       restart = true;
         alias_database = "\$alias_maps";
 
         ### Virtual mailboxes config
-        virtual_alias_maps = "hash:/etc/postfix/virtual mysql:${config.secrets.fullPaths."postfix/mysql_alias_maps"} ldap:${config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"}";
+        virtual_alias_maps = [
+          "hash:/etc/postfix/virtual"
+          "mysql:${config.secrets.fullPaths."postfix/mysql_alias_maps"}"
+          "ldap:${config.secrets.fullPaths."postfix/ldap_ejabberd_users_immae_fr"}"
+        ];
         virtual_mailbox_domains = config.myEnv.mail.postfix.additional_mailbox_domains
         ++ lib.remove null (lib.flatten (map
             (zone: map
             )
             config.myEnv.dns.masterZones
           ));
-        virtual_mailbox_maps = "hash:/etc/postfix/host_dummy_mailboxes mysql:${config.secrets.fullPaths."postfix/mysql_mailbox_maps"}";
+        virtual_mailbox_maps = [
+          "hash:/etc/postfix/host_dummy_mailboxes"
+          "mysql:${config.secrets.fullPaths."postfix/mysql_mailbox_maps"}"
+        ];
         dovecot_destination_recipient_limit = "1";
         virtual_transport = "dovecot";
 
         smtp_use_tls = true;
         smtpd_use_tls = true;
         smtpd_tls_chain_files = builtins.concatStringsSep "," [ "/var/lib/acme/mail/full.pem" "/var/lib/acme/mail-rsa/full.pem" ];
+
+        maximal_queue_lifetime = "6w";
+        bounce_queue_lifetime = "6w";
       };
       enable = true;
       enableSmtp = true;
         "smtp.immae.eu" = null;
       };
     };
+    security.acme.certs."mail-rsa" = {
+      postRun = ''
+        systemctl restart postfix.service
+        '';
+      extraDomains = {
+        "smtp.immae.eu" = null;
+      };
+    };
     system.activationScripts.testmail = {
       deps = [ "users" ];
       text = let