]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/mail/dovecot.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / mail / dovecot.nix
index ae06f2f0f2b22f191a740c06d47f528f6017f7d4..3c3ae3d4cc08466a32549fd1dc3edc8fdc867c76 100644 (file)
@@ -13,6 +13,29 @@ let
 in
 {
   config = lib.mkIf config.myServices.mail.enable {
+    myServices.chatonsProperties.services.email = {
+      file.datetime = "2022-08-22T01:00:00";
+      service = {
+        name = "E-mail account";
+        description = "Compte e-mail avec configuration imap et smtp/pop3";
+        logo = "https://www.dovecot.org/wp-content/uploads/2021/09/favicon.ico";
+        website = "https://mail.immae.eu/";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["MEMBER" "CLIENT"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Dovecot";
+        website = "https://www.dovecot.org/";
+        license.url = "https://github.com/dovecot/core/blob/main/COPYING";
+        license.name = "MIT and LGPLv2.1 Licenses";
+        version = pkgs.dovecot.version;
+        source.url = "https://github.com/dovecot/core";
+        modules = ["roundcube" "rainloop"] ++ map (a: a.pname) config.services.dovecot2.modules;
+      };
+    };
     systemd.services.dovecot2.serviceConfig.Slice = "mail.slice";
     secrets.keys."dovecot/ldap" = {
       user = config.services.dovecot2.user;