]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/irc.nix
Fix patrick certificate
[perso/Immae/Config/Nix.git] / modules / private / irc.nix
index 9871508041f870238e569316a051a689eaaedb36..459d87c7bb79ad9cbb3e2d870cb1b6c5745194ad 100644 (file)
@@ -17,8 +17,29 @@ in
   };
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.irc = {
-      rootDir = "/var/lib/bitlbee";
+    myServices.chatonsProperties.services.bitlbee = {
+      file.datetime = "2022-08-27T19:00:00";
+      service = {
+        name = "Bitlbee";
+        description = "An IRC to other chat networks gateway";
+        logo = "https://www.bitlbee.org/style/logo.png";
+        website = "irc.immae.eu";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["MEMBER" "CLIENT"];
+        registration.load = "FULL";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "BitlBee";
+        website = "https://www.bitlbee.org/";
+        license.url = "https://github.com/bitlbee/bitlbee/blob/master/COPYING";
+        license.name = "GNU General Public License v2.0";
+        version = pkgs.bitlbee.version;
+        source.url = "https://github.com/bitlbee/bitlbee";
+        modules = map (a: a.pname) config.services.bitlbee.plugins
+          ++ map (a: a.pname) config.services.bitlbee.libpurple_plugins;
+      };
     };
     security.acme.certs."irc" = config.myServices.ircCerts // {
       domain = "irc.immae.eu";
@@ -34,6 +55,8 @@ in
       libpurple_plugins = [
         purple-hangouts
         purple-matrix
+        purple-facebook
+        purple-googlechat
       ];
       plugins = [
         bitlbee-mastodon