]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add cip-ca mail website
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 7555fe67236cfe7becf5ea444cdc428ed7671054..ec9bf29f3c5d2736a2822482f2eed75b5cabd52a 100644 (file)
@@ -450,6 +450,7 @@ in
             type = attrsOf (submodule {
               options = {
                 keep = mkOption { type = int; description = "Number of backups to keep"; };
+                check_command = mkOption { type = str; description = "command to check if backup needs to be done"; default = "backup"; };
                 login = mkOption { type = str; description = "Login to connect to host"; };
                 port = mkOption { type = str; default = "22"; description = "Port to connect to host"; };
                 host = mkOption { type = str; description = "Host to connect to"; };
@@ -650,6 +651,7 @@ in
                   user_attrs = mkOption { type = str; description = "User attribute mapping in LDAP"; };
                   iterate_attrs = mkOption { type = str; description = "User attribute mapping for listing in LDAP"; };
                   iterate_filter = mkOption { type = str; description = "User attribute filter for listing in LDAP"; };
+                  postfix_mailbox_filter = mkOption { type = str; description = "Postfix filter to get mailboxes"; };
                 };
               };
             };