]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
WIP openfoodnetwork
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 837d24be95e65a9251ba93b54163fc48b6f4a113..e469138a9fa51928560520ebd1f5e74b745d0b41 100644 (file)
@@ -871,13 +871,15 @@ in
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
                 workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
-                  type = attrsOf str;
-                  description = "Secrets for the project to dump as files";
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
+                  description = "Secrets for the project to dump as files. Might be a function that takes pkgs as argument";
                 };
                 environment = mkOption {
-                  type = attrsOf str;
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
                   description = ''
-                    Environment variables for the project.
+                    Environment variables for the project. Might be a function that takes pkgs as argument.
                     BUILDBOT_ is prefixed to the variable names
                   '';
                 };
@@ -1245,6 +1247,23 @@ in
       description = "Websites configurations";
       type = submodule {
         options = {
+          christophe_carpentier = mkOption {
+            description = "Christophe Carpentier configuration by environment";
+            type = submodule {
+              options = {
+                agorakit = mkOption {
+                  description = "Agorakit configuration";
+                  type = submodule {
+                    options = {
+                      mysql = mkMysqlOptions "Agorakit" {};
+                      smtp = mkSmtpOptions "Agorakit";
+                      appkey = mkOption { type = str; description = "App key"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           immae = mkOption {
             description = "Immae configuration by environment";
             type = submodule {
@@ -1313,6 +1332,16 @@ in
                   options = {
                     production = chloeSubmodule;
                     integration = chloeSubmodule;
+                    new = mkOption {
+                      description = "environment configuration";
+                      type = submodule {
+                        options = {
+                          mysql = mkMysqlOptions "ChloeNew" {};
+                          ldap = mkLdapOptions "ChloeNew" {};
+                          secret = mkOption { type = str; description = "Symfony App secret"; };
+                        };
+                      };
+                    };
                   };
                 };
           };
@@ -1379,6 +1408,35 @@ in
                   };
                 };
           };
+          nicecoop = mkOption {
+            description = "Nicecoop configuration";
+            type = submodule {
+              options = {
+                odoo = {
+                  port = mkOption { description = "Port to listen to"; type = port; };
+                  longpoll_port = mkOption { description = "Port to listen to"; type = port; };
+                  postgresql = mkPsqlOptions "Odoo";
+                  admin_password = mkOption { type = str; description = "Admin password"; };
+                };
+                gestion-compte = {
+                  smtp = mkSmtpOptions "GestionCompte";
+                  mysql = mkMysqlOptions "gestion-compte" {};
+                  secret = mkOption { type = str; description = "Application secret"; };
+                  adminpassword = mkOption { type = str; description = "Admin password"; };
+                };
+                gestion-compte-integration = {
+                  smtp = mkSmtpOptions "GestionCompte";
+                  mysql = mkMysqlOptions "gestion-compte" {};
+                  secret = mkOption { type = str; description = "Application secret"; };
+                  adminpassword = mkOption { type = str; description = "Admin password"; };
+                };
+                copanier = {
+                  smtp = mkSmtpOptions "Copanier";
+                  staff = mkOption { type = listOf str; description = "List of staff members"; };
+                };
+              };
+            };
+          };
           emilia = mkOption {
             description = "Emilia configuration";
             type = submodule {