]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Rework integration websites
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index d0615ac90ddb7f6d3126f1743782e24c3d8dfc74..e469138a9fa51928560520ebd1f5e74b745d0b41 100644 (file)
@@ -871,13 +871,15 @@ in
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
                 workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
-                  type = attrsOf str;
-                  description = "Secrets for the project to dump as files";
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
+                  description = "Secrets for the project to dump as files. Might be a function that takes pkgs as argument";
                 };
                 environment = mkOption {
-                  type = attrsOf str;
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
                   description = ''
-                    Environment variables for the project.
+                    Environment variables for the project. Might be a function that takes pkgs as argument.
                     BUILDBOT_ is prefixed to the variable names
                   '';
                 };
@@ -1330,6 +1332,16 @@ in
                   options = {
                     production = chloeSubmodule;
                     integration = chloeSubmodule;
+                    new = mkOption {
+                      description = "environment configuration";
+                      type = submodule {
+                        options = {
+                          mysql = mkMysqlOptions "ChloeNew" {};
+                          ldap = mkLdapOptions "ChloeNew" {};
+                          secret = mkOption { type = str; description = "Symfony App secret"; };
+                        };
+                      };
+                    };
                   };
                 };
           };