]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Add milter to verify from
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 7da248004a3e47c0540da7e31f9cd98eff2a7892..c4c32c8e34a32d6392ac920eb8e80f10baa0fb1d 100644 (file)
@@ -420,7 +420,6 @@ in
         '';
       type = submodule {
         options = {
-          mailto = mkOption { type = str; description = "Where to e-mail on error"; };
           ssh_key = mkOption {
             description = "SSH key information";
             type = submodule {
@@ -494,8 +493,8 @@ in
                 port = mkOption { type = nullOr str; default = null; description = "Port to connect to ssh"; };
                 login = mkOption { type = nullOr str; default = null; description = "Login to connect to ssh"; };
                 targets = mkOption { type = listOf str; description = "Hosts to send E-mails to"; };
-                mail_address = mkOption { type = str; description = "E-mail recipient part to send e-mail to"; };
-                mail_domain = mkOption { type = str; description = "E-mail domain part to send e-mail to"; };
+                mail_address = mkOption { type = nullOr str; default = null; description = "E-mail recipient part to send e-mail to"; };
+                mail_domain = mkOption { type = nullOr str; default = null; description = "E-mail domain part to send e-mail to"; };
               };
             });
           };