]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Flake webapps
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 719bf8f01b9b4cf6cbe996f7ad36c8e05b1411b8..7b13870d578d948c90357da63a54da0eb4810634 100644 (file)
@@ -169,9 +169,10 @@ let
         type = attrsOf (submodule {
           options = {
             ip4 = mkOption {
-              type = str;
+              type = listOf str;
+              default = [];
               description = ''
-                ip4 address of the host
+                ip4 addresses of the host
               '';
             };
             ip6 = mkOption {
@@ -228,6 +229,7 @@ in
       '';
       type = submodule {
         options = {
+          rootKeys = mkOption { type = attrsOf str; description = "Keys of root users"; };
           ldap = mkOption {
             description = ''
               LDAP credentials for cn=ssh,ou=services,dc=immae,dc=eu dn
@@ -491,6 +493,15 @@ in
             };
           };
           mysql = mkMysqlOptions "Zrepl" {};
+          certs = mkOption {
+            description = "Certificates";
+            type = attrsOf (submodule {
+              options = {
+                key = mkOption { type = str; description = "Key"; };
+                certificate = mkOption { type = str; description = "Certificate"; };
+              };
+            });
+          };
         };
       };
     };
@@ -574,15 +585,6 @@ in
               };
             };
           };
-          eban = mkOption {
-            description = "Eban credentials for webhook";
-            type = submodule {
-              options = {
-                user = mkOption { type = str; description = "User"; };
-                password = mkOption { type = str; description = "Password"; };
-              };
-            };
-          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
@@ -620,7 +622,10 @@ in
       description = "FTP configuration";
       type = submodule {
         options = {
-          ldap = mkLdapOptions "FTP" {};
+          ldap = mkLdapOptions "FTP" {
+            proftpd_filter = mkOption { type = str; description = "Filter for proftpd listing in LDAP"; };
+            pure-ftpd_filter = mkOption { type = str; description = "Filter for pure-ftpd listing in LDAP"; };
+          };
         };
       };
     };
@@ -800,10 +805,28 @@ in
         };
       };
     };
+    coturn = mkOption {
+      description = "Coturn configuration";
+      type = submodule {
+        options = {
+          auth_access_key = mkOption { type = str; description = "key to access coturn"; };
+        };
+      };
+    };
     buildbot = mkOption {
       description = "Buildbot configuration";
       type = submodule {
         options = {
+          ssh_key = mkOption {
+            description = "SSH key information";
+            type = submodule {
+              options = {
+                public = mkOption { type = str; description = "Public part of the key"; };
+                private = mkOption { type = lines; description = "Private part of the key"; };
+              };
+            };
+          };
+          workerPassword = mkOption { description = "Buildbot worker password"; type = str; };
           user = mkOption {
             description = "Buildbot user";
             type = submodule {
@@ -843,26 +866,18 @@ in
                     Takes pkgs as argument.
                   '';
                 };
-                pythonPackages = mkOption {
-                  type = unspecified;
-                  example = literalExample ''
-                    p: pkgs: [ pkgs.python3Packages.pip ];
-                    '';
-                  description = ''
-                    Function.
-                    Builds python packages list to make available to buildbot project.
-                    Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
-                    '';
-                };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
+                workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
-                  type = attrsOf str;
-                  description = "Secrets for the project to dump as files";
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
+                  description = "Secrets for the project to dump as files. Might be a function that takes pkgs as argument";
                 };
                 environment = mkOption {
-                  type = attrsOf str;
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
                   description = ''
-                    Environment variables for the project.
+                    Environment variables for the project. Might be a function that takes pkgs as argument.
                     BUILDBOT_ is prefixed to the variable names
                   '';
                 };
@@ -949,7 +964,6 @@ in
                 adminPassword = mkOption { type = str; description = "Admin password for mypads / admin"; };
                 session_key = mkOption { type = str; description = "Session key"; };
                 api_key = mkOption { type = str; description = "API key"; };
-                redirects = mkOption { type = str; description = "Redirects for apache"; };
               };
             };
           };
@@ -958,6 +972,15 @@ in
             type = submodule {
               options = {
                 ldap = mkLdapOptions "Gitolite" {};
+                ssh_key = mkOption {
+                  description = "SSH key information";
+                  type = submodule {
+                    options = {
+                      public = mkOption { type = str; description = "Public part of the key"; };
+                      private = mkOption { type = lines; description = "Private part of the key"; };
+                    };
+                  };
+                };
               };
             };
           };
@@ -1151,7 +1174,6 @@ in
               options = {
                 report_uri = mkOption { type = str; description = "URI to report CSP violations to"; };
                 policies = mkOption { type = attrsOf str; description = "CSP policies to apply"; };
-                postgresql = mkPsqlOptions "CSP reports";
               };
             };
           };
@@ -1221,6 +1243,23 @@ in
       description = "Websites configurations";
       type = submodule {
         options = {
+          christophe_carpentier = mkOption {
+            description = "Christophe Carpentier configuration by environment";
+            type = submodule {
+              options = {
+                agorakit = mkOption {
+                  description = "Agorakit configuration";
+                  type = submodule {
+                    options = {
+                      mysql = mkMysqlOptions "Agorakit" {};
+                      smtp = mkSmtpOptions "Agorakit";
+                      appkey = mkOption { type = str; description = "App key"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           immae = mkOption {
             description = "Immae configuration by environment";
             type = submodule {
@@ -1289,6 +1328,16 @@ in
                   options = {
                     production = chloeSubmodule;
                     integration = chloeSubmodule;
+                    new = mkOption {
+                      description = "environment configuration";
+                      type = submodule {
+                        options = {
+                          mysql = mkMysqlOptions "ChloeNew" {};
+                          ldap = mkLdapOptions "ChloeNew" {};
+                          secret = mkOption { type = str; description = "Symfony App secret"; };
+                        };
+                      };
+                    };
                   };
                 };
           };
@@ -1355,6 +1404,35 @@ in
                   };
                 };
           };
+          nicecoop = mkOption {
+            description = "Nicecoop configuration";
+            type = submodule {
+              options = {
+                odoo = {
+                  port = mkOption { description = "Port to listen to"; type = port; };
+                  longpoll_port = mkOption { description = "Port to listen to"; type = port; };
+                  postgresql = mkPsqlOptions "Odoo";
+                  admin_password = mkOption { type = str; description = "Admin password"; };
+                };
+                gestion-compte = {
+                  smtp = mkSmtpOptions "GestionCompte";
+                  mysql = mkMysqlOptions "gestion-compte" {};
+                  secret = mkOption { type = str; description = "Application secret"; };
+                  adminpassword = mkOption { type = str; description = "Admin password"; };
+                };
+                gestion-compte-integration = {
+                  smtp = mkSmtpOptions "GestionCompte";
+                  mysql = mkMysqlOptions "gestion-compte" {};
+                  secret = mkOption { type = str; description = "Application secret"; };
+                  adminpassword = mkOption { type = str; description = "Admin password"; };
+                };
+                copanier = {
+                  smtp = mkSmtpOptions "Copanier";
+                  staff = mkOption { type = listOf str; description = "List of staff members"; };
+                };
+              };
+            };
+          };
           emilia = mkOption {
             description = "Emilia configuration";
             type = submodule {
@@ -1458,13 +1536,6 @@ in
         };
       };
     };
-
-    privateFiles = mkOption {
-      type = path;
-      description = ''
-        Path to secret files to make available during build
-        '';
-    };
   };
   options.hostEnv = mkOption {
     readOnly = true;