]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Flake webapps
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 32e7208b916d8f6ade3d41d7f64f291754fae280..7b13870d578d948c90357da63a54da0eb4810634 100644 (file)
@@ -493,6 +493,15 @@ in
             };
           };
           mysql = mkMysqlOptions "Zrepl" {};
+          certs = mkOption {
+            description = "Certificates";
+            type = attrsOf (submodule {
+              options = {
+                key = mkOption { type = str; description = "Key"; };
+                certificate = mkOption { type = str; description = "Certificate"; };
+              };
+            });
+          };
         };
       };
     };
@@ -857,17 +866,6 @@ in
                     Takes pkgs as argument.
                   '';
                 };
-                pythonPackages = mkOption {
-                  type = unspecified;
-                  example = literalExample ''
-                    p: pkgs: [ pkgs.python3Packages.pip ];
-                    '';
-                  description = ''
-                    Function.
-                    Builds python packages list to make available to buildbot project.
-                    Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
-                    '';
-                };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
                 workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {