]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Flake webapps
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 27f36e5973eebdb32513c47c3e428305551e74fa..7b13870d578d948c90357da63a54da0eb4810634 100644 (file)
@@ -169,9 +169,10 @@ let
         type = attrsOf (submodule {
           options = {
             ip4 = mkOption {
-              type = str;
+              type = listOf str;
+              default = [];
               description = ''
-                ip4 address of the host
+                ip4 addresses of the host
               '';
             };
             ip6 = mkOption {
@@ -492,6 +493,15 @@ in
             };
           };
           mysql = mkMysqlOptions "Zrepl" {};
+          certs = mkOption {
+            description = "Certificates";
+            type = attrsOf (submodule {
+              options = {
+                key = mkOption { type = str; description = "Key"; };
+                certificate = mkOption { type = str; description = "Certificate"; };
+              };
+            });
+          };
         };
       };
     };
@@ -575,15 +585,6 @@ in
               };
             };
           };
-          eban = mkOption {
-            description = "Eban credentials for webhook";
-            type = submodule {
-              options = {
-                user = mkOption { type = str; description = "User"; };
-                password = mkOption { type = str; description = "Password"; };
-              };
-            };
-          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
           slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
           slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
@@ -804,6 +805,14 @@ in
         };
       };
     };
+    coturn = mkOption {
+      description = "Coturn configuration";
+      type = submodule {
+        options = {
+          auth_access_key = mkOption { type = str; description = "key to access coturn"; };
+        };
+      };
+    };
     buildbot = mkOption {
       description = "Buildbot configuration";
       type = submodule {
@@ -857,27 +866,18 @@ in
                     Takes pkgs as argument.
                   '';
                 };
-                pythonPackages = mkOption {
-                  type = unspecified;
-                  example = literalExample ''
-                    p: pkgs: [ pkgs.python3Packages.pip ];
-                    '';
-                  description = ''
-                    Function.
-                    Builds python packages list to make available to buildbot project.
-                    Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
-                    '';
-                };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
                 workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
-                  type = attrsOf str;
-                  description = "Secrets for the project to dump as files";
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
+                  description = "Secrets for the project to dump as files. Might be a function that takes pkgs as argument";
                 };
                 environment = mkOption {
-                  type = attrsOf str;
+                  #type = attrsOf (either str (functionTo str));
+                  type = attrsOf unspecified;
                   description = ''
-                    Environment variables for the project.
+                    Environment variables for the project. Might be a function that takes pkgs as argument.
                     BUILDBOT_ is prefixed to the variable names
                   '';
                 };
@@ -964,7 +964,6 @@ in
                 adminPassword = mkOption { type = str; description = "Admin password for mypads / admin"; };
                 session_key = mkOption { type = str; description = "Session key"; };
                 api_key = mkOption { type = str; description = "API key"; };
-                redirects = mkOption { type = str; description = "Redirects for apache"; };
               };
             };
           };
@@ -1175,7 +1174,6 @@ in
               options = {
                 report_uri = mkOption { type = str; description = "URI to report CSP violations to"; };
                 policies = mkOption { type = attrsOf str; description = "CSP policies to apply"; };
-                postgresql = mkPsqlOptions "CSP reports";
               };
             };
           };
@@ -1330,6 +1328,16 @@ in
                   options = {
                     production = chloeSubmodule;
                     integration = chloeSubmodule;
+                    new = mkOption {
+                      description = "environment configuration";
+                      type = submodule {
+                        options = {
+                          mysql = mkMysqlOptions "ChloeNew" {};
+                          ldap = mkLdapOptions "ChloeNew" {};
+                          secret = mkOption { type = str; description = "Symfony App secret"; };
+                        };
+                      };
+                    };
                   };
                 };
           };
@@ -1407,6 +1415,7 @@ in
                   admin_password = mkOption { type = str; description = "Admin password"; };
                 };
                 gestion-compte = {
+                  smtp = mkSmtpOptions "GestionCompte";
                   mysql = mkMysqlOptions "gestion-compte" {};
                   secret = mkOption { type = str; description = "Application secret"; };
                   adminpassword = mkOption { type = str; description = "Admin password"; };
@@ -1417,6 +1426,10 @@ in
                   secret = mkOption { type = str; description = "Application secret"; };
                   adminpassword = mkOption { type = str; description = "Admin password"; };
                 };
+                copanier = {
+                  smtp = mkSmtpOptions "Copanier";
+                  staff = mkOption { type = listOf str; description = "List of staff members"; };
+                };
               };
             };
           };