]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Postfix common aliases
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 1cc3b6cc315752657b603321337245786c7c0ef1..47eafaba0b892ac274e1d410c9f1f4fac68124c4 100644 (file)
@@ -684,6 +684,24 @@ in
                 mysql = mkMysqlOptions "Postfix" {
                   password_encrypt = mkOption { type = str; description = "Key to encrypt relay password in database"; };
                 };
+                admins = mkOption {
+                  description = ''
+                    List of admins meant to receive common aliases
+                  '';
+                  type = listOf str;
+                };
+                common_aliases = mkOption {
+                  description = ''
+                    List of aliases common to all hosts, to forward to admins
+                  '';
+                  type = listOf str;
+                };
+                other_aliases = mkOption {
+                  description = ''
+                    Other list of aliases, to forward to admins
+                  '';
+                  type = listOf str;
+                };
                 backup_domains = mkOption {
                   description = ''
                     Domains that are accepted for relay as backup domain