]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Improve assets generation
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index ae00298039b2921ac74f97ab369fec84197a0255..1cc3b6cc315752657b603321337245786c7c0ef1 100644 (file)
@@ -908,6 +908,8 @@ in
             default = {};
             type = attrsOf (submodule {
               options = {
+                assetType = mkOption { type = enum ["tgz" "url" "googleFont"]; default = "url"; description = "Type of asset"; };
+                tgzRemoveComponents = mkOption { type = int; default = 0; description = "Remove components when extracting"; };
                 url = mkOption { type = str; description = "URL to fetch"; };
                 sha256 = mkOption { type = str; description = "Hash of the url"; };
               };