]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Fix converse
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 14fbd621ff6cc308c5b787fdd3ffc7568cb4c9c1..1cc3b6cc315752657b603321337245786c7c0ef1 100644 (file)
@@ -169,9 +169,10 @@ let
         type = attrsOf (submodule {
           options = {
             ip4 = mkOption {
-              type = str;
+              type = listOf str;
+              default = [];
               description = ''
-                ip4 address of the host
+                ip4 addresses of the host
               '';
             };
             ip6 = mkOption {
@@ -492,6 +493,15 @@ in
             };
           };
           mysql = mkMysqlOptions "Zrepl" {};
+          certs = mkOption {
+            description = "Certificates";
+            type = attrsOf (submodule {
+              options = {
+                key = mkOption { type = str; description = "Key"; };
+                certificate = mkOption { type = str; description = "Certificate"; };
+              };
+            });
+          };
         };
       };
     };
@@ -575,18 +585,8 @@ in
               };
             };
           };
-          eban = mkOption {
-            description = "Eban credentials for webhook";
-            type = submodule {
-              options = {
-                user = mkOption { type = str; description = "User"; };
-                password = mkOption { type = str; description = "Password"; };
-              };
-            };
-          };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
-          slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
-          slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
+          apprise_urls = mkOption { type = str; description = "Apprise space-separated urls to push status update"; };
           netdata_aggregator = mkOption { type = str; description = "Url where netdata information should be sent"; };
           netdata_keys = mkOption { type = attrsOf str; description = "netdata host keys"; };
           contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
@@ -865,17 +865,6 @@ in
                     Takes pkgs as argument.
                   '';
                 };
-                pythonPackages = mkOption {
-                  type = unspecified;
-                  example = literalExample ''
-                    p: pkgs: [ pkgs.python3Packages.pip ];
-                    '';
-                  description = ''
-                    Function.
-                    Builds python packages list to make available to buildbot project.
-                    Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
-                    '';
-                };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
                 workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
@@ -897,15 +886,6 @@ in
                     Activation script to run during deployment
                   '';
                 };
-                builderPaths = mkOption {
-                  type = attrsOf unspecified;
-                  default = {};
-                  description = ''
-                    Attrs of functions to make accessible specifically per builder.
-                    Takes pkgs as argument and should return a single path containing binaries.
-                    This path will be accessible as BUILDBOT_PATH_<attrskey>
-                    '';
-                };
                 webhookTokens = mkOption {
                   type = nullOr (listOf str);
                   default = null;
@@ -928,6 +908,8 @@ in
             default = {};
             type = attrsOf (submodule {
               options = {
+                assetType = mkOption { type = enum ["tgz" "url" "googleFont"]; default = "url"; description = "Type of asset"; };
+                tgzRemoveComponents = mkOption { type = int; default = 0; description = "Remove components when extracting"; };
                 url = mkOption { type = str; description = "URL to fetch"; };
                 sha256 = mkOption { type = str; description = "Hash of the url"; };
               };
@@ -974,7 +956,6 @@ in
                 adminPassword = mkOption { type = str; description = "Admin password for mypads / admin"; };
                 session_key = mkOption { type = str; description = "Session key"; };
                 api_key = mkOption { type = str; description = "API key"; };
-                redirects = mkOption { type = str; description = "Redirects for apache"; };
               };
             };
           };
@@ -1185,7 +1166,6 @@ in
               options = {
                 report_uri = mkOption { type = str; description = "URI to report CSP violations to"; };
                 policies = mkOption { type = attrsOf str; description = "CSP policies to apply"; };
-                postgresql = mkPsqlOptions "CSP reports";
               };
             };
           };