]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Fix converse
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 069f3558a444a2e7d72aec27b9b54b6c10c537c4..1cc3b6cc315752657b603321337245786c7c0ef1 100644 (file)
@@ -586,8 +586,7 @@ in
             };
           };
           nrdp_tokens = mkOption { type = listOf str; description = "Tokens allowed to push status update"; };
-          slack_url = mkOption { type = str; description = "Slack webhook url to push status update"; };
-          slack_channel = mkOption { type = str; description = "Slack channel to push status update"; };
+          apprise_urls = mkOption { type = str; description = "Apprise space-separated urls to push status update"; };
           netdata_aggregator = mkOption { type = str; description = "Url where netdata information should be sent"; };
           netdata_keys = mkOption { type = attrsOf str; description = "netdata host keys"; };
           contacts = mkOption { type = attrsOf unspecified; description = "Contact dicts to fill naemon objects"; };
@@ -866,17 +865,6 @@ in
                     Takes pkgs as argument.
                   '';
                 };
-                pythonPackages = mkOption {
-                  type = unspecified;
-                  example = literalExample ''
-                    p: pkgs: [ pkgs.python3Packages.pip ];
-                    '';
-                  description = ''
-                    Function.
-                    Builds python packages list to make available to buildbot project.
-                    Takes buildbot python module as first argument and pkgs as second argument in order to augment the python modules list.
-                    '';
-                };
                 pythonPathHome = mkOption { type = bool; description = "Whether to add project’s python home to python path"; };
                 workerPort = mkOption { type = port; description = "Port for the worker"; };
                 secrets = mkOption {
@@ -898,15 +886,6 @@ in
                     Activation script to run during deployment
                   '';
                 };
-                builderPaths = mkOption {
-                  type = attrsOf unspecified;
-                  default = {};
-                  description = ''
-                    Attrs of functions to make accessible specifically per builder.
-                    Takes pkgs as argument and should return a single path containing binaries.
-                    This path will be accessible as BUILDBOT_PATH_<attrskey>
-                    '';
-                };
                 webhookTokens = mkOption {
                   type = nullOr (listOf str);
                   default = null;
@@ -929,6 +908,8 @@ in
             default = {};
             type = attrsOf (submodule {
               options = {
+                assetType = mkOption { type = enum ["tgz" "url" "googleFont"]; default = "url"; description = "Type of asset"; };
+                tgzRemoveComponents = mkOption { type = int; default = 0; description = "Remove components when extracting"; };
                 url = mkOption { type = str; description = "URL to fetch"; };
                 sha256 = mkOption { type = str; description = "Hash of the url"; };
               };