]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/environment.nix
Redirect websites landing pages
[perso/Immae/Config/Nix.git] / modules / private / environment.nix
index 2aa8b5e272c9a9f9924e447cbed7be0594bcaa9a..15e8f5489f56729d4f00d471cb49c04ed8746f32 100644 (file)
@@ -951,8 +951,8 @@ in
       description = "Websites configurations";
       type = submodule {
         options = {
-          aten = mkOption {
-            description = "Aten configurations by environment";
+          isabelle = mkOption {
+            description = "Isabelle configurations by environment";
             type =
               let
                 atenSubmodule = mkOption {
@@ -968,8 +968,8 @@ in
               in
                 submodule {
                   options = {
-                    production = atenSubmodule;
-                    integration = atenSubmodule;
+                    aten_production = atenSubmodule;
+                    aten_integration = atenSubmodule;
                   };
                 };
           };
@@ -1104,6 +1104,23 @@ in
                   };
                 };
           };
+          richie = mkOption {
+            description = "Europe Richie configurations by environment";
+            type = submodule {
+              options = {
+                mysql = mkMysqlOptions "Richie";
+                smtp_mailer = mkOption {
+                  description = "SMTP mailer configuration";
+                  type = submodule {
+                    options = {
+                      user = mkOption { type = str; description = "Username"; };
+                      password = mkOption { type = str; description = "Password"; };
+                    };
+                  };
+                };
+              };
+            };
+          };
           tellesflorian = mkOption {
             description = "Tellesflorian configurations by environment";
             type =