]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/coturn.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / coturn.nix
index 41e836b27b2ee2cea0caca4e88ad38d04c0a316a..d8b02c5dd6a5fd8b950394622b2689e3b424b5f3 100644 (file)
@@ -1,6 +1,26 @@
-{ config, name, lib, ... }:
+{ config, name, lib, pkgs, ... }:
 {
   config = lib.mkIf (name == "eldiron") {
+    myServices.chatonsProperties.services.coturn = {
+      file.datetime = "2022-08-27T19:00:00";
+      service = {
+        name = "Coturn";
+        description = "coturn TURN server";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["MEMBER" "CLIENT"];
+        registration.load = "FULL";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "coturn";
+        website = "https://github.com/coturn/coturn";
+        license.url = "https://github.com/coturn/coturn/blob/master/LICENSE";
+        license.name = "3-Clause BSD License";
+        version = pkgs.coturn.version;
+        source.url = "https://github.com/coturn/coturn";
+      };
+    };
     networking.firewall.allowedTCPPorts = [
       config.services.coturn.alt-listening-port
       config.services.coturn.alt-tls-listening-port