]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/buildbot/default.nix
Add chatons infos
[perso/Immae/Config/Nix.git] / modules / private / buildbot / default.nix
index 3ee1f8be3b46d1de9dfba9008b3ec811878071db..d9e5966edc82d525eb15ae9285fd0e6836ad5ffe 100644 (file)
@@ -16,6 +16,29 @@ in
   };
 
   config = lib.mkIf config.myServices.buildbot.enable {
+    myServices.chatonsProperties.hostings.buildbot = {
+      file.datetime = "2022-08-21T10:37:00";
+      hosting = {
+        name = "Buildbot";
+        description = "Python-based continuous integration testing framework";
+        type = "INSTANCE";
+        website = "https://git.immae.eu";
+        logo = "https://www.buildbot.net/img/icon.png";
+        status.level = "OK";
+        status.description = "OK";
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+        guide.user = "https://www.immae.eu/docs/forge-logicielle.html";
+      };
+      software = {
+        name = "Buildbot";
+        website = "https://www.buildbot.net/";
+        license.url = "https://github.com/buildbot/buildbot/blob/master/LICENSE";
+        license.name = "GNU General Public License v2.0";
+        version = pkgs.buildbot.version;
+        source.url = "https://github.com/buildbot/buildbot";
+      };
+    };
     nixpkgs.overlays = [
       (self: super: {
         follow-systemd-unit = self.writeScriptBin "follow-systemd-unit" ''