]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/buildbot/default.nix
Rework integration websites
[perso/Immae/Config/Nix.git] / modules / private / buildbot / default.nix
index ec28b632d799b7ad6822fafd89e54e8dfa36d15f..d86853959c47ce4d63a83b200eb05c70aef000cb 100644 (file)
@@ -80,7 +80,7 @@ in
               permissions = "0600";
               user = "buildbot";
               group = "buildbot";
-              text = v;
+              text = if builtins.isFunction v then v pkgs else v;
             })
           ) project.secrets
           ++ [
@@ -98,7 +98,7 @@ in
               group = "buildbot";
               text = let
                 project_env = with lib.attrsets;
-                  mapAttrs' (k: v: nameValuePair "BUILDBOT_${k}" v) project.environment //
+                  mapAttrs' (k: v: nameValuePair "BUILDBOT_${k}" (if builtins.isFunction v then v pkgs else v)) project.environment //
                   mapAttrs' (k: v: nameValuePair "BUILDBOT_PATH_${k}" (v pkgs)) (attrByPath ["builderPaths"] {} project) //
                   {
                     BUILDBOT_PROJECT_DIR = ./projects + "/${project.name}";