]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/mypackages/pkgs/gearmand/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / pkgs / gearmand / default.nix
diff --git a/flakes/mypackages/pkgs/gearmand/default.nix b/flakes/mypackages/pkgs/gearmand/default.nix
new file mode 100644 (file)
index 0000000..14ef8c2
--- /dev/null
@@ -0,0 +1,16 @@
+{ stdenv, fetchurl, boost, gperf, libevent, libmysqlclient, libuuid, sqlite, hiredis, postgresql, openssl }:
+stdenv.mkDerivation rec {
+  pname = "gearmand";
+  version = "1.1.20";
+  src = fetchurl {
+    url = "https://github.com/gearman/${pname}/releases/download/${version}/${pname}-${version}.tar.gz";
+    sha256 = "sha256-L2D6IH3NcwWV75ap3DyomVZnB8gXYQazxj7PR+3BR6Y=";
+  };
+  buildInputs = [ boost gperf libevent openssl libmysqlclient libuuid sqlite hiredis postgresql ];
+  configureFlags = [
+    "--with-boost=${boost.dev}"
+    "--with-boost-libdir=${boost}/lib"
+    "--with-openssl=${openssl.dev}"
+    "--enable-ssl"
+  ];
+}