]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/mypackages/lib/flake-parts-lib.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / mypackages / lib / flake-parts-lib.nix
diff --git a/flakes/mypackages/lib/flake-parts-lib.nix b/flakes/mypackages/lib/flake-parts-lib.nix
new file mode 100644 (file)
index 0000000..271a4cf
--- /dev/null
@@ -0,0 +1,10 @@
+i@{ name, type }:
+{ lib, flake-parts-lib, ... }:
+flake-parts-lib.mkTransposedPerSystemModule {
+  inherit name;
+  option = lib.mkOption {
+    type = lib.types.lazyAttrsOf lib.types."${type}";
+    default = { };
+  };
+  file = import ./flake-parts-lib.nix i;
+}