]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/lib/flake.nix
Add flake skeletons
[perso/Immae/Config/Nix.git] / flakes / lib / flake.nix
index a352c4c018a4a395c52cb600cc0cba4d452b2e1a..ab1a6aa881eb8f387eda2044692f7a5c1bea51e0 100644 (file)
@@ -4,13 +4,6 @@
   description = "Useful libs";
   outputs = { self, nixpkgs }: {
     lib = rec {
-      withNarKeyCompat = flakeCompat: path: moduleAttrs:
-        let module = (flakeCompat path).${moduleAttrs};
-            key = builtins.hashString "sha256" (builtins.path { inherit path; name = "source"; });
-        in if builtins.isFunction module
-          then args@{ config, lib, pkgs, ... }: (module args // { inherit key; })
-          else module // { inherit key; };
-
       withNarKey = dep: moduleAttrs:
         let module = dep.${moduleAttrs};
             key = builtins.hashString "sha256" (builtins.path { path = dep.sourceInfo.outPath; name = "source"; });