]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/etherpad-lite/modules/ep_subscript_and_superscript/node-packages.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / etherpad-lite / modules / ep_subscript_and_superscript / node-packages.nix
diff --git a/flakes/etherpad-lite/modules/ep_subscript_and_superscript/node-packages.nix b/flakes/etherpad-lite/modules/ep_subscript_and_superscript/node-packages.nix
new file mode 100644 (file)
index 0000000..04065dd
--- /dev/null
@@ -0,0 +1,28 @@
+# This file has been generated by node2nix 1.8.0. Do not edit!
+
+{nodeEnv, fetchurl, fetchgit, globalBuildInputs ? []}:
+
+let
+  sources = {};
+in
+{
+  ep_subscript_and_superscript = nodeEnv.buildNodePackage {
+    name = "ep_subscript_and_superscript";
+    packageName = "ep_subscript_and_superscript";
+    version = "0.0.3";
+    src = fetchurl {
+      url = "https://registry.npmjs.org/ep_subscript_and_superscript/-/ep_subscript_and_superscript-0.0.3.tgz";
+      sha1 = "47f74a242fe8be5911391943f718eab81c390620";
+    };
+    preRebuild = ''
+      patch -p1 < ${./font.patch}
+    '';
+    buildInputs = globalBuildInputs;
+    meta = {
+      description = "Add support for Subscript and Superscript";
+    };
+    production = true;
+    bypassCache = true;
+    reconstructLock = true;
+  };
+}