]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flakes/etherpad-lite/modules/ep_scrollto/node-packages.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flakes / etherpad-lite / modules / ep_scrollto / node-packages.nix
diff --git a/flakes/etherpad-lite/modules/ep_scrollto/node-packages.nix b/flakes/etherpad-lite/modules/ep_scrollto/node-packages.nix
new file mode 100644 (file)
index 0000000..8f7656f
--- /dev/null
@@ -0,0 +1,29 @@
+# This file has been generated by node2nix 1.8.0. Do not edit!
+
+{nodeEnv, fetchurl, fetchgit, globalBuildInputs ? []}:
+
+let
+  sources = {};
+in
+{
+  ep_scrollto = nodeEnv.buildNodePackage {
+    name = "ep_scrollto";
+    packageName = "ep_scrollto";
+    version = "0.0.7";
+    src = fetchurl {
+      url = "https://registry.npmjs.org/ep_scrollto/-/ep_scrollto-0.0.7.tgz";
+      sha512 = "uUfpiUWO0xLhN2R89jMPUYD+vhyiPyH6b8QL7y+0bKiOYOqf9l/rgXwTLuf4iB3p0J1/oVXhgSkG0dlZ35bUWw==";
+    };
+    buildInputs = globalBuildInputs;
+    preRebuild = ''
+      sed -i -e "s/is_old_ie = browser.msie.*$/is_old_ie = false;/" static/js/postAceInit.js
+    '';
+    meta = {
+      description = "Scroll to a specific line number based on a parameter of lineNumber in the URL IE http://test.com/p/foo#lineNumber=10 -- Users can click on the line number to get a link";
+      homepage = "https://github.com/johnmclear/ep_scrollto#readme";
+    };
+    production = true;
+    bypassCache = true;
+    reconstructLock = true;
+  };
+}