]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - flake.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / flake.nix
diff --git a/flake.nix b/flake.nix
new file mode 100644 (file)
index 0000000..e3ed4c9
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,47 @@
+{
+  description = "immae-eu infrastructure";
+  inputs = {
+    flake-parts.url = "github:hercules-ci/flake-parts";
+    devshell.url = "github:numtide/devshell";
+    # nixpkgs for local tools
+    nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+
+    flakes.url = "path:./flakes";
+  };
+  outputs = inputs@{ self, flake-parts, flakes, ... }:
+    let
+      inherit (flakes.subflakes) public private;
+      inherit (public) mypackages;
+    in
+      flake-parts.lib.mkFlake { inherit inputs; } ({ withSystem, ... }: {
+        imports = [
+          inputs.devshell.flakeModule
+          (mypackages.mylibs.flakePartsAddPerSystem { name = "lib"; type = "unspecified"; })
+        ];
+        systems = [ "x86_64-linux" ];
+        perSystem = { config, inputs', pkgs, system, ... }:
+          {
+            packages = mypackages.packages."${system}";
+            lib = mypackages.lib."${system}";
+            devshells.default = {
+              packages = [
+                pkgs.colmena
+                pkgs.nixUnstable pkgs.python3 pkgs.sops
+                pkgs.curl pkgs.shellcheck pkgs.jq
+                pkgs.gnumake pkgs.yq
+              ];
+              env = [
+                { name = "NIX_BUILD_TOP"; value = ""; }
+                { name = "PATH"; prefix = "scripts"; }
+                { name = "NIX_PATH"; value = "nixpkgs=${pkgs.path}"; }
+              ];
+            };
+          };
+        flake = {
+          # FIXME: next line Can be removed in nix 2.16.*
+          devShell.x86_64-linux = self.devShells.x86_64-linux.default;
+          inherit (mypackages) mylibs sources overlays;
+          inherit (flakes) subflakes;
+        };
+      });
+}