]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Temporarily fix mastodon package
[perso/Immae/Config/Nix.git] / default.nix
index 444d29d8b4a67509b29747daaf2240aa97d82bcf..e5fc5f4ac598e741772c53c48331a7775fc27062 100644 (file)
@@ -1,5 +1,5 @@
-with import <immaeNixpkgsNext> {};
-with import ./libs.nix { nixpkgs = import <immaeNixpkgsNext> {}; };
+with import <nixpkgs> {};
+with import ./libs.nix { nixpkgs = import <nixpkgs> {}; };
 let
   mypkgs = {};
 
@@ -63,19 +63,11 @@ let
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
-  mypkgs.weechat = (wrapWeechat (
-    weechat-unwrapped.overrideAttrs (old: rec {
-      version = "2.3";
-      name = "weechat-${version}";
-      src = fetchurl {
-        url = "https://weechat.org/files/src/weechat-${version}.tar.bz2";
-        sha256 = "0mi4pfnyny0vqc35r0scn6yy21y790a5iwq8ms7kch7b7z11jn9w";
-      };
-      patches = [];
-    })
-  ) {}).override {
+  mypkgs.weechat = weechat.override {
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
+          # Make sure websocket_client is not 0.55.0, it provokes
+          # regular crashes
          (python.withPackages (ps: with ps; [websocket_client emoji]))
          perl
          ruby
@@ -101,7 +93,7 @@ let
     };
   };
 
-  mypkgs.terminal-velocity = with python3Packages; buildPythonApplication rec {
+  mypkgs.terminal-velocity = with python36Packages; buildPythonApplication rec {
     pname = "terminal-velocity-git";
     version = "0.2.0";
 
@@ -169,6 +161,7 @@ let
     configureFlags = [
       "--with-etc-dir=/etc/cnagios"
       "--with-var-dir=/var/lib/naemon"
+      "--with-status-file=/var/lib/naemon/status.dat"
       "--with-nagios-data=4"
     ];
 
@@ -687,4 +680,7 @@ in
     inherit bc;
     inherit cpulimit;
     inherit dmenu st;
+    inherit poppler_utils;
+    inherit tmux;
+    inherit netcat-gnu;
   }