]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add stgit progam
[perso/Immae/Config/Nix.git] / default.nix
index c32d23f569e6ed47d3058c435958f8ac79c46fd1..a76cf7a3737789c9c5e08584ec1eb56d8a8d5604 100644 (file)
@@ -244,8 +244,8 @@ let
 
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
-      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
-      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+      export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
@@ -258,7 +258,7 @@ let
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
-      jemalloc which postgresql python3
+      jemalloc which postgresql python3 cacert
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
@@ -301,6 +301,7 @@ in
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
+    stgit = gitAndTools.stgit;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;