]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add stgit progam
[perso/Immae/Config/Nix.git] / default.nix
index 9f14e5a33ce47a347e190ce38fec8731f886e2ec..a76cf7a3737789c9c5e08584ec1eb56d8a8d5604 100644 (file)
@@ -1,5 +1,7 @@
-with import <nixpkgs> {};
+with import ./libs.nix;
+with nixpkgs_unstable;
 let
+  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
@@ -16,24 +18,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -101,7 +85,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -260,8 +244,8 @@ let
 
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
-      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
-      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+      export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
@@ -274,7 +258,7 @@ let
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
-      jemalloc which postgresql python3
+      jemalloc which postgresql python3 cacert
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
@@ -316,6 +300,8 @@ in
     inherit keybase;
     inherit bogofilter;
     inherit mtr;
+    inherit nixops;
+    stgit = gitAndTools.stgit;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;