]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add stgit progam
[perso/Immae/Config/Nix.git] / default.nix
index 3772d44afd6e8c64549307f42e226d24fb2bd1f9..a76cf7a3737789c9c5e08584ec1eb56d8a8d5604 100644 (file)
@@ -1,10 +1,5 @@
-with import (builtins.fetchTarball {
-  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
-  # versions
-  name = "nixos-unstable-2018-12-08";
-  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
-  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
-}) {};
+with import ./libs.nix;
+with nixpkgs_unstable;
 let
   stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
@@ -23,24 +18,6 @@ let
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -267,8 +244,8 @@ let
 
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
-      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
-      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+      export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
@@ -281,7 +258,7 @@ let
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
-      jemalloc which postgresql python3
+      jemalloc which postgresql python3 cacert
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
@@ -324,6 +301,7 @@ in
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
+    stgit = gitAndTools.stgit;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;