]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add some new programs: weechat profanity ranger
[perso/Immae/Config/Nix.git] / default.nix
index 1844121f457f5b118c141e111c305e72f983b17b..4592eefe2bcff94d6518aa6f72075c0e3c7c8afa 100644 (file)
@@ -10,6 +10,15 @@ let
       src = fetchFromGitHub json.github;
     };
 
+  fetchedGit = path:
+    let
+      json = lib.importJSON path;
+    in rec {
+      version = json.tag;
+      name = "${json.meta.name}-${version}";
+      src = fetchgit json.git;
+    };
+
   ledger = (nixpkgs.ledger.override { boost = boost166; }).overrideAttrs (oldAttrs:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -50,13 +59,55 @@ let
     configureFlags = oldAttrs.configureFlags ++ [ "--with-slrnpull" ];
   });
 
-  #weechat = callPackage nixpkgs.weechat { guileSupport = false; luaSupport = false; rubySupport = false; tclSupport = false; };
+  ldapvi = nixpkgs.ldapvi.overrideAttrs (oldAttrs: fetchedGit ./fetched/ldapvi.json);
+
+  nixos = import ./nixos_tools.nix {};
+
+  pass = nixpkgs.pass.overrideAttrs (oldAttrs:
+    fetchedGit ./fetched/pass.json // {
+      patches = oldAttrs.patches ++ [ ./patches/pass-fix-pass-init.patch ];
+    }
+  );
+
+  profanity = (nixpkgs.profanity.override {
+    notifySupport = true;
+    inherit libnotify gpgme gdk_pixbuf;
+    python = python3;
+  }).overrideAttrs (oldAttrs: rec {
+    configureFlags = oldAttrs.configureFlags ++ [ "--enable-plugins" ];
+  });
+
+  weechat = nixpkgs.weechat.override {
+    configure = { availablePlugins, ... }: {
+      plugins = with availablePlugins; [
+         (python.withPackages (ps: with ps; [websocket_client emoji]))
+         perl
+        ];
+    };
+  };
+
 in
   {
     inherit nix-prefetch-scripts;
     inherit ledger;
-    inherit taskwarrior vit;
+    inherit taskwarrior vit timewarrior;
     inherit weboob;
     inherit slrn;
     inherit sc-im;
+    inherit ldapvi;
+    inherit pal;
+    inherit duplicity duply;
+    inherit pdftk;
+    inherit googler;
+    inherit jrnl;
+    inherit apg;
+    inherit newsboat;
+    inherit vcsh;
+    inherit xmr-stak;
+    inherit urlwatch;
+    inherit pass;
+    inherit ranger;
+    inherit profanity;
+    inherit weechat;
+    #inherit nixos;
   }