]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Use tagged nixpkgs instead of last unstable version to control upgrades
[perso/Immae/Config/Nix.git] / default.nix
index 61b5d25504d376414dec2c48e6e432ad0ca72bce..3772d44afd6e8c64549307f42e226d24fb2bd1f9 100644 (file)
@@ -1,5 +1,12 @@
-with import <nixpkgs> {};
+with import (builtins.fetchTarball {
+  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
+  # versions
+  name = "nixos-unstable-2018-12-08";
+  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
+  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
+}) {};
 let
+  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
@@ -101,7 +108,7 @@ let
     };
   };
 
-  buildPerlPackage = callPackage <nixpkgs/pkgs/development/perl-modules/generic> { };
+  buildPerlPackage = perlPackages.buildPerlPackage;
   mypkgs.note = buildPerlPackage rec {
     name = "note-1.3.26";
     src = fetchurl {
@@ -257,6 +264,26 @@ let
   #     cp docs/nagnu.8 $out/share/man/man8
   #     '';
   # });
+
+  mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
+    buildPhase = ''
+      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
+      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+
+      bundle install --deployment --without development test
+      yarn install --pure-lockfile
+    '';
+    installPhase = ''
+      cp -a . $out
+    '';
+    propagatedBuildInputs = [
+      zlib icu libchardet git bundler yarn
+      protobuf protobufc libidn libpqxx nodejs
+      imagemagick ffmpeg libxml2 libxslt pkgconfig
+      autoconf bison libyaml readline ncurses libffi gdbm
+      jemalloc which postgresql python3
+    ];
+  });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
 in
@@ -296,6 +323,8 @@ in
     inherit keybase;
     inherit bogofilter;
     inherit mtr;
+    inherit nixops;
+    #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;