]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Fix build dependency for note
[perso/Immae/Config/Nix.git] / default.nix
index ea7127474430d4ab60cef69c066d6b62a6d52ab3..11dcf0d05f09d079d03b642a8fbc2cd77633de7a 100644 (file)
@@ -78,7 +78,7 @@ let
 
   nixos = import ./nixos_tools.nix {};
 
-  pass = nixpkgs.pass.overrideAttrs (oldAttrs:
+  pass = (nixpkgs.pass.withExtensions (exts: [ exts.pass-otp ])).overrideAttrs (oldAttrs:
     fetchedGit ./fetched/pass.json // {
       patches = oldAttrs.patches ++ [ ./patches/pass-fix-pass-init.patch ];
     }
@@ -109,7 +109,7 @@ let
       sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
     };
     outputs = ["out" "man"];
-    buildInputs = [ perlPackages.YAML ];
+    propragatedBuildInputs = [ perlPackages.YAML ];
     meta = with stdenv.lib; {
       description = "A perl script for maintaining notes";
       homepage    = http://www.daemon.de/NOTE;
@@ -256,5 +256,17 @@ in
     inherit graphicsmagick;
     inherit youtube-dl;
     inherit pg_activity pgloader;
+    inherit ncmpc;
+    inherit cadaver;
+    inherit mairix notmuch;
+    inherit ctags;
+    inherit s3cmd;
+    inherit solc; # solidity
+    inherit rtorrent;
+    inherit strace;
+    inherit vdirsyncer;
+    inherit w3m lynx links;
+    inherit gitRepo;
+    inherit valgrind;
     #inherit nixos;
   }