]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Add statistics for aten website
[perso/Immae/Config/Nix.git] / default.nix
index c32d23f569e6ed47d3058c435958f8ac79c46fd1..c2776023bf5627eb12a4cab6bdd2afd1dff180a8 100644 (file)
@@ -1,7 +1,6 @@
 with import ./libs.nix;
 with import ./libs.nix;
-with nixpkgs_unstable;
+with import <nixpkgs> {};
 let
 let
-  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
   mypkgs = {};
   postHook =  ''
     header() {
@@ -76,7 +75,7 @@ let
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
-  mypkgs.weechat = weechat.override {
+  mypkgs.weechat = nixpkgs_unstable.weechat.override {
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
          (python.withPackages (ps: with ps; [websocket_client emoji]))
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
          (python.withPackages (ps: with ps; [websocket_client emoji]))
@@ -93,7 +92,7 @@ let
       sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
     };
     outputs = ["out" "man"];
       sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
     };
     outputs = ["out" "man"];
-    propragatedBuildInputs = [ perlPackages.YAML ];
+    propagatedBuildInputs = [ perlPackages.YAML ];
     meta = with stdenv.lib; {
       description = "A perl script for maintaining notes";
       homepage    = http://www.daemon.de/NOTE;
     meta = with stdenv.lib; {
       description = "A perl script for maintaining notes";
       homepage    = http://www.daemon.de/NOTE;
@@ -113,7 +112,7 @@ let
       ./patches/terminal_velocity_sort_found_notes.patch
     ];
 
       ./patches/terminal_velocity_sort_found_notes.patch
     ];
 
-    propagatedBuildInputs = [ chardet urwid sh pyyaml ];
+    propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
     buildInputs = [ m2r restructuredtext_lint pygments ];
 
     src = fetchPypi {
     buildInputs = [ m2r restructuredtext_lint pygments ];
 
     src = fetchPypi {
@@ -242,10 +241,21 @@ let
   #     '';
   # });
 
   #     '';
   # });
 
+  mypkgs.goaccess = goaccess.overrideAttrs(old: rec {
+    name = "goaccess-${version}";
+    version = "1.3";
+    src = fetchurl {
+      url = "https://tar.goaccess.io/${name}.tar.gz";
+      sha256 = "16vv3pj7pbraq173wlxa89jjsd279004j4kgzlrsk1dz4if5qxwc";
+    };
+    configureFlags = old.configureFlags ++ [ "--enable-tcb=btree" ];
+    buildInputs = old.buildInputs ++ [ tokyocabinet bzip2 ];
+  });
+
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
-      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
-      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+      export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
@@ -258,7 +268,7 @@ let
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
-      jemalloc which postgresql python3
+      jemalloc which postgresql python3 cacert
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
@@ -270,7 +280,6 @@ in
     inherit timewarrior;
     inherit sc-im;
     inherit pal;
     inherit timewarrior;
     inherit sc-im;
     inherit pal;
-    inherit duplicity duply;
     inherit pdftk;
     inherit googler;
     inherit jrnl;
     inherit pdftk;
     inherit googler;
     inherit jrnl;
@@ -301,8 +310,24 @@ in
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
+    stgit = gitAndTools.stgit;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;
-  }
+  } // (with nixpkgs_unstable; {
+    inherit googler;
+    inherit khal;
+    inherit newsboat;
+    inherit xmr-stak;
+    inherit urlwatch;
+    inherit graphicsmagick;
+    inherit ncmpc;
+    inherit solc;
+    inherit w3m lynx links;
+    inherit valgrind;
+    inherit ranger;
+    inherit strace;
+    inherit notmuch;
+    stgit = gitAndTools.stgit;
+  })