]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - default.nix
Replace unstable with stable in environment
[perso/Immae/Config/Nix.git] / default.nix
index 3772d44afd6e8c64549307f42e226d24fb2bd1f9..4e50c59f397510a10e7a725c6a18a4f55a9d757c 100644 (file)
@@ -1,12 +1,6 @@
-with import (builtins.fetchTarball {
-  # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
-  # versions
-  name = "nixos-unstable-2018-12-08";
-  url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
-  sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
-}) {};
+with import ./libs.nix;
+with import <nixpkgs> {};
 let
 let
-  stable_nixpkgs = import <nixpkgs> {};
   mypkgs = {};
   postHook =  ''
     header() {
   mypkgs = {};
   postHook =  ''
     header() {
@@ -23,24 +17,6 @@ let
     }
   '';
 
     }
   '';
 
-  fetchedGithub = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchFromGitHub json.github;
-    };
-
-  fetchedGit = path:
-    let
-      json = lib.importJSON path;
-    in rec {
-      version = json.tag;
-      name = "${json.meta.name}-${version}";
-      src = fetchgit json.git;
-    };
-
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
   mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
     fetchedGithub ./fetched/ledger.json // {
       postInstall = "";
@@ -99,7 +75,7 @@ let
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
     configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
   });
 
-  mypkgs.weechat = weechat.override {
+  mypkgs.weechat = nixpkgs_unstable.weechat.override {
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
          (python.withPackages (ps: with ps; [websocket_client emoji]))
     configure = { availablePlugins, ... }: {
       plugins = with availablePlugins; [
          (python.withPackages (ps: with ps; [websocket_client emoji]))
@@ -116,7 +92,7 @@ let
       sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
     };
     outputs = ["out" "man"];
       sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
     };
     outputs = ["out" "man"];
-    propragatedBuildInputs = [ perlPackages.YAML ];
+    propagatedBuildInputs = [ perlPackages.YAML ];
     meta = with stdenv.lib; {
       description = "A perl script for maintaining notes";
       homepage    = http://www.daemon.de/NOTE;
     meta = with stdenv.lib; {
       description = "A perl script for maintaining notes";
       homepage    = http://www.daemon.de/NOTE;
@@ -136,7 +112,7 @@ let
       ./patches/terminal_velocity_sort_found_notes.patch
     ];
 
       ./patches/terminal_velocity_sort_found_notes.patch
     ];
 
-    propagatedBuildInputs = [ chardet urwid sh pyyaml ];
+    propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
     buildInputs = [ m2r restructuredtext_lint pygments ];
 
     src = fetchPypi {
     buildInputs = [ m2r restructuredtext_lint pygments ];
 
     src = fetchPypi {
@@ -267,8 +243,8 @@ let
 
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
 
   mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
     buildPhase = ''
-      export GIT_SSL_CAINFO=/etc/ssl/certs/ca-certificates.crt
-      export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
+      export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
+      export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
 
       bundle install --deployment --without development test
       yarn install --pure-lockfile
@@ -281,7 +257,7 @@ let
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
       protobuf protobufc libidn libpqxx nodejs
       imagemagick ffmpeg libxml2 libxslt pkgconfig
       autoconf bison libyaml readline ncurses libffi gdbm
-      jemalloc which postgresql python3
+      jemalloc which postgresql python3 cacert
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
     ];
   });
 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
@@ -293,7 +269,6 @@ in
     inherit timewarrior;
     inherit sc-im;
     inherit pal;
     inherit timewarrior;
     inherit sc-im;
     inherit pal;
-    inherit duplicity duply;
     inherit pdftk;
     inherit googler;
     inherit jrnl;
     inherit pdftk;
     inherit googler;
     inherit jrnl;
@@ -324,8 +299,24 @@ in
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
     inherit bogofilter;
     inherit mtr;
     inherit nixops;
+    stgit = gitAndTools.stgit;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;
     #inherit mastodon;
     # todo: lx* ?, unrar, unzip, zeromq?
     #inherit nextcloud-client;
     #inherit nixos;
-  }
+  } // (with nixpkgs_unstable; {
+    inherit googler;
+    inherit khal;
+    inherit newsboat;
+    inherit xmr-stak;
+    inherit urlwatch;
+    inherit graphicsmagick;
+    inherit ncmpc;
+    inherit solc;
+    inherit w3m lynx links;
+    inherit valgrind;
+    inherit ranger;
+    inherit strace;
+    inherit notmuch;
+    stgit = gitAndTools.stgit;
+  })