]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - virtual/packages.nix
Import additional packages
[perso/Immae/Config/Nix.git] / virtual / packages.nix
1 with import (builtins.fetchTarball {
2 # FIXME: upgrade to nixpkgs 19 when stable and stick to stable
3 # versions
4 name = "nixos-unstable-2018-12-08";
5 url = https://github.com/nixos/nixpkgs/archive/61c3169a0e17d789c566d5b241bfe309ce4a6275.tar.gz;
6 sha256 = "0qbycg7wkb71v20rchlkafrjfpbk2fnlvvbh3ai9pyfisci5wxvq";
7 }) {};
8 let
9 adminer = pkgs.stdenv.mkDerivation rec {
10 name = "adminer-4.7.0";
11 src = pkgs.fetchurl {
12 url = "https://www.adminer.org/static/download/4.7.0/${name}.php";
13 sha256 = "1qq2g7rbfh2vrqfm3g0bz0qs057b049n0mhabnsbd1sgnpvnc5z7";
14 };
15 phases = "installPhase";
16 installPhase = ''
17 mkdir -p $out
18 cp $src $out/index.php
19 '';
20 };
21
22 in
23 {
24 inherit adminer;
25 }