]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/default.nix
Add new packages
[perso/Immae/Config/Nix.git] / pkgs / default.nix
1 { pkgs }:
2 with pkgs;
3 let
4 mylibs = import ../lib { inherit pkgs; };
5 in
6 rec {
7 sources = import ../nix/sources.nix;
8 myEnvironments = callPackage ../environments {};
9 bash-libs = callPackage ./bash-libs {};
10 boinctui = callPackage ./boinctui {};
11 cnagios = callPackage ./cnagios { inherit mylibs; };
12 commento = callPackage ./commento {};
13 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
14 fluentd = callPackage ./fluentd {};
15 fluent-bit = callPackage ./fluent-bit {};
16 genius = callPackage ./genius {};
17 ical2html = callPackage ./ical2html {};
18 mtop = callPackage ./mtop {};
19 muttprint = callPackage ./muttprint {};
20 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
21 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
22 nagnu = callPackage ./nagnu { inherit mylibs; };
23 nb = callPackage ./nb {};
24 note = callPackage ./note {};
25 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
26 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python38Packages; };
27 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
28 perl-ical-parser-html = callPackage ./perl-ical-parser-html {};
29 pgpid = callPackage ./pgpid {};
30 predixy = callPackage ./predixy { inherit mylibs; };
31 riotkit-do = callPackage ./riotkit-do {};
32 rrsync_sudo = callPackage ./rrsync_sudo {};
33 signaldctl = callPackage ./signaldctl {};
34 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
35 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
36 terminal-velocity = callPackage ./terminal-velocity {};
37 tiv = callPackage ./tiv {};
38 twins = callPackage ./twins {};
39 upcmd = callPackage ./upcmd {};
40 umami = callPackage ./umami {};
41 unicodeDoc = callPackage ./unicode {};
42
43 cardano = callPackage ./crypto/cardano { inherit mylibs; };
44 cardano-cli = callPackage ./crypto/cardano-cli {};
45 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
46 sia = callPackage ./crypto/sia {};
47
48 proftpd = callPackage ./proftpd {};
49 pure-ftpd = callPackage ./pure-ftpd {};
50
51 composerEnv = callPackage ./composer-env {};
52 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
53
54 monitoring-plugins = callPackage ./monitoring-plugins {};
55 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
56 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
57 gearmand = callPackage ./gearmand {};
58 status_engine = {
59 module = callPackage ./status_engine/module.nix { inherit mylibs; };
60 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
61 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
62 };
63
64 python3PackagesPlus = callPackage ./python-packages {
65 python = python38;
66 inherit mylibs;
67 };
68 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
69 inherit mylibs;
70 };
71 }