]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - pkgs/default.nix
Bump backports
[perso/Immae/Config/Nix.git] / pkgs / default.nix
1 { pkgs }:
2 with pkgs;
3 let
4 mylibs = import ../lib { inherit pkgs; };
5 in
6 rec {
7 sources = import ../nix/sources.nix;
8 myEnvironments = callPackage ../environments {};
9 bash-libs = callPackage ./bash-libs {};
10 boinctui = callPackage ./boinctui {};
11 cnagios = callPackage ./cnagios { inherit mylibs; };
12 commento = callPackage ./commento {};
13 flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
14 fluentd = callPackage ./fluentd {};
15 fluent-bit = callPackage ./fluent-bit {};
16 genius = callPackage ./genius {};
17 ical2html = callPackage ./ical2html {};
18 mtop = callPackage ./mtop {};
19 muttprint = callPackage ./muttprint {};
20 mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
21 nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
22 nagnu = callPackage ./nagnu { inherit mylibs; };
23 nb = callPackage ./nb {};
24 note = callPackage ./note {};
25 notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
26 notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python38Packages; };
27 notmuch-vim = callPackage ./notmuch/notmuch-vim {};
28 pgpid = callPackage ./pgpid {};
29 predixy = callPackage ./predixy { inherit mylibs; };
30 rrsync_sudo = callPackage ./rrsync_sudo {};
31 signaldctl = callPackage ./signaldctl {};
32 telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
33 telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
34 terminal-velocity = callPackage ./terminal-velocity {};
35 tiv = callPackage ./tiv {};
36 twins = callPackage ./twins {};
37 umami = callPackage ./umami {};
38 unicodeDoc = callPackage ./unicode {};
39
40 cardano = callPackage ./crypto/cardano { inherit mylibs; };
41 cardano-cli = callPackage ./crypto/cardano-cli {};
42 iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
43 sia = callPackage ./crypto/sia {};
44
45 proftpd = callPackage ./proftpd {};
46 pure-ftpd = callPackage ./pure-ftpd {};
47
48 composerEnv = callPackage ./composer-env {};
49 webapps = callPackage ./webapps { inherit mylibs composerEnv; };
50
51 monitoring-plugins = callPackage ./monitoring-plugins {};
52 naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
53 naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
54 gearmand = callPackage ./gearmand {};
55 status_engine = {
56 module = callPackage ./status_engine/module.nix { inherit mylibs; };
57 worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
58 interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
59 };
60
61 python3PackagesPlus = callPackage ./python-packages {
62 python = python38;
63 inherit mylibs;
64 };
65 dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
66 inherit mylibs;
67 };
68 }