]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/websites/php-application.nix
Rework integration websites
[perso/Immae/Config/Nix.git] / modules / websites / php-application.nix
1 { lib, config, pkgs, ... }:
2 with lib;
3 let
4 cfg = config.services.phpApplication;
5 cfgByEnv = lists.groupBy (x: x.websiteEnv) (builtins.attrValues cfg.apps);
6 in
7 {
8 options = with types; {
9 services.phpApplication.apps = mkOption {
10 default = {};
11 description = ''
12 php applications to define
13 '';
14 type = attrsOf (submodule {
15 options = {
16 varDir = mkOption {
17 type = nullOr path;
18 description = ''
19 Path to application’s vardir.
20 '';
21 };
22 varDirPaths = mkOption {
23 type = attrsOf str;
24 default = {};
25 description = ''
26 Map of additional folders => mode to create under varDir
27 '';
28 };
29 mode = mkOption {
30 type = str;
31 default = "0700";
32 description = ''
33 Mode to apply to the vardir
34 '';
35 };
36 phpSession = mkOption {
37 type = bool;
38 default = true;
39 description = "Handle phpsession files separately in vardir";
40 };
41 phpListen = mkOption {
42 type = nullOr str;
43 default = null;
44 description = "Name of the socket to listen to. Defaults to app name if null";
45 };
46 phpPool = mkOption {
47 type = attrsOf str;
48 default = {};
49 description = "Pool configuration to append";
50 };
51 phpEnv = mkOption {
52 type = attrsOf str;
53 default = {};
54 description = "Pool environment to append";
55 };
56 phpPackage = mkOption {
57 type = attrsOf str;
58 default = pkgs.php;
59 description = "Php package to use";
60 };
61 phpOptions = mkOption {
62 type = lines;
63 default = "";
64 description = "php configuration to append";
65 };
66 phpOpenbasedir = mkOption {
67 type = listOf path;
68 default = [];
69 description = ''
70 paths to add to php open_basedir configuration in addition to app and vardir
71 '';
72 };
73 phpWatchFiles = mkOption {
74 type = listOf path;
75 default = [];
76 description = ''
77 Path to other files to watch to trigger preStart scripts
78 '';
79 };
80 websiteEnv = mkOption {
81 type = str;
82 description = ''
83 website instance name to use
84 '';
85 };
86 httpdUser = mkOption {
87 type = str;
88 default = config.services.httpd.user;
89 description = ''
90 httpd user to run the prestart scripts as.
91 '';
92 };
93 httpdGroup = mkOption {
94 type = str;
95 default = config.services.httpd.group;
96 description = ''
97 httpd group to run the prestart scripts as.
98 '';
99 };
100 httpdWatchFiles = mkOption {
101 type = listOf path;
102 default = [];
103 description = ''
104 Path to other files to watch to trigger httpd reload
105 '';
106 };
107 app = mkOption {
108 type = path;
109 description = ''
110 Path to application root
111 '';
112 };
113 preStartActions = mkOption {
114 type = listOf str;
115 default = [];
116 description = ''
117 List of actions to run as apache user at preStart when
118 whatchFiles or app dir changed.
119 '';
120 };
121 serviceDeps = mkOption {
122 type = listOf str;
123 default = [];
124 description = ''
125 List of systemd services this application depends on
126 '';
127 };
128 };
129 });
130 };
131 # Read-only variables
132 services.phpApplication.phpListenPaths = mkOption {
133 type = attrsOf path;
134 default = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
135 name config.services.phpfpm.pools."${name}".socket
136 ) cfg.apps;
137 readOnly = true;
138 description = ''
139 Full paths to listen for php
140 '';
141 };
142 };
143
144 config = {
145 services.websites.env = attrsets.mapAttrs' (name: cfgs: attrsets.nameValuePair
146 name {
147 modules = [ "proxy_fcgi" ];
148 watchPaths = builtins.concatLists (map (c: c.httpdWatchFiles) cfgs);
149 }
150 ) cfgByEnv;
151
152 services.phpfpm.pools = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
153 name {
154 user = icfg.httpdUser;
155 group = icfg.httpdUser;
156 settings = {
157 "listen.owner" = icfg.httpdUser;
158 "listen.group" = icfg.httpdGroup;
159 "php_admin_value[open_basedir]" = builtins.concatStringsSep ":" ([icfg.app icfg.varDir] ++ icfg.phpWatchFiles ++ icfg.phpOpenbasedir);
160 }
161 // optionalAttrs (icfg.phpSession) { "php_admin_value[session.save_path]" = "${icfg.varDir}/phpSessions"; }
162 // icfg.phpPool;
163 phpOptions = config.services.phpfpm.phpOptions + icfg.phpOptions;
164 inherit (icfg) phpEnv phpPackage;
165 }
166 ) cfg.apps;
167
168 services.filesWatcher = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
169 "phpfpm-${name}" {
170 restart = true;
171 paths = icfg.phpWatchFiles;
172 }
173 ) (attrsets.filterAttrs (n: v: builtins.length v.phpWatchFiles > 0) cfg.apps);
174
175 systemd.services = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
176 "phpfpm-${name}" {
177 after = lib.mkAfter icfg.serviceDeps;
178 wants = icfg.serviceDeps;
179 preStart = lib.mkAfter (optionalString (!isNull icfg.varDir) ''
180 watchFilesChanged() {
181 ${optionalString (builtins.length icfg.phpWatchFiles == 0) "return 1"}
182 [ ! -f "${icfg.varDir}"/watchedFiles ] \
183 || ! sha512sum -c --status ${icfg.varDir}/watchedFiles
184 }
185 appDirChanged() {
186 [ ! -f "${icfg.varDir}/currentWebappDir" -o \
187 "${icfg.app}" != "$(cat ${icfg.varDir}/currentWebappDir 2>/dev/null)" ]
188 }
189 updateWatchFiles() {
190 ${optionalString (builtins.length icfg.phpWatchFiles == 0) "return 0"}
191 sha512sum ${builtins.concatStringsSep " " icfg.phpWatchFiles} > ${icfg.varDir}/watchedFiles
192 }
193
194 if watchFilesChanged || appDirChanged; then
195 pushd ${icfg.app} > /dev/null
196 ${builtins.concatStringsSep "\n " (map (c: "/run/wrappers/bin/sudo -u ${icfg.httpdUser} ${c}") icfg.preStartActions) }
197 popd > /dev/null
198 echo -n "${icfg.app}" > ${icfg.varDir}/currentWebappDir
199 updateWatchFiles
200 fi
201 '');
202 }
203 ) cfg.apps;
204
205 system.activationScripts = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
206 name {
207 deps = [];
208 text = optionalString (!isNull icfg.varDir) ''
209 install -m ${icfg.mode} -o ${icfg.httpdUser} -g ${icfg.httpdGroup} -d ${icfg.varDir}
210 '' + optionalString (icfg.phpSession) ''
211 install -m 0700 -o ${icfg.httpdUser} -g ${icfg.httpdGroup} -d ${icfg.varDir}/phpSessions
212 '' + builtins.concatStringsSep "\n" (attrsets.mapAttrsToList (n: v: ''
213 install -m ${v} -o ${icfg.httpdUser} -g ${icfg.httpdGroup} -d ${icfg.varDir}/${n}
214 '') icfg.varDirPaths);
215 }
216 ) cfg.apps;
217 };
218 }