1 { lib, pkgs, config, ... }:
3 partModule = lib.types.submodule {
5 remote_folder = lib.mkOption {
11 exclude_from = lib.mkOption {
12 type = lib.types.listOf lib.types.path;
15 Paths to exclude from the backup
18 files_from = lib.mkOption {
19 type = lib.types.listOf lib.types.path;
22 Paths to take for the backup
23 (if empty: whole folder minus exclude_from)
27 type = lib.types.nullOr lib.types.str;
30 additional arguments for rsync
35 profileModule = lib.types.submodule {
41 Number of backups to keep
44 check_command = lib.mkOption {
48 command to check if backup needs to be done
51 login = lib.mkOption {
70 host_key = lib.mkOption {
73 Host key to use as known host
76 host_key_type = lib.mkOption {
82 parts = lib.mkOption {
83 type = lib.types.attrsOf partModule;
85 folders to backup in the host
90 cfg = config.services.rsyncBackup;
92 ssh_key = config.secrets.fullPaths."rsync_backup/identity";
95 #!${pkgs.stdenv.shell}
101 if [ -s "$TMP_STDERR" ]; then
104 rm -f $TMP_STDERR $EXCL_FROM $FILES_FROM
109 exec 2> "$TMP_STDERR"
115 backup_profile = name: profile: builtins.concatStringsSep "\n" (
116 [(backup_profile_head name profile)]
117 ++ lib.mapAttrsToList (backup_part name) profile.parts
118 ++ [(backup_profile_tail name profile)]);
120 backup_profile_head = name: profile: ''
122 PORT="${profile.port}"
123 DEST="${profile.login}@${profile.host}"
124 BASE="${cfg.mountpoint}/${name}"
125 OLD_BAK_BASE=$BASE/older/j
126 BAK_BASE=''${OLD_BAK_BASE}0
127 RSYNC_OUTPUT=$BASE/rsync_output
128 NBR=${builtins.toString profile.keep}
131 -o PreferredAuthentications=publickey \
132 -o StrictHostKeyChecking=yes \
133 -o ClearAllForwardings=yes \
134 -o UserKnownHostsFile=/dev/null \
138 $DEST ${profile.check_command}; then
139 echo "Fichier de verrouillage backup sur $DEST ou impossible de se connecter" >&2
143 rm -rf ''${OLD_BAK_BASE}''${NBR}
144 for j in `seq -w $(($NBR-1)) -1 0`; do
145 [ ! -d ''${OLD_BAK_BASE}$j ] && continue
146 mv ''${OLD_BAK_BASE}$j ''${OLD_BAK_BASE}$(($j+1))
149 mv $RSYNC_OUTPUT $BAK_BASE
152 if [ "$skip" != "$DEST" ]; then
155 backup_profile_tail = name: profile: ''
156 ssh -o UserKnownHostsFile=/dev/null -o CheckHostIP=no -i ${ssh_key} -p $PORT $DEST sh -c "date > .cache/last_backup"
157 fi # [ "$skip" != "$DEST" ]
158 ##### End ${name} #####
161 backup_part = profile_name: part_name: part: ''
162 ### ${profile_name} ${part_name} ###
164 REMOTE="${part.remote_folder}"
166 if [ ! -d "$BASE/$LOCAL" ]; then
170 cat > $EXCL_FROM <<EOF
171 ${builtins.concatStringsSep "\n" part.exclude_from}
173 cat > $FILES_FROM <<EOF
174 ${builtins.concatStringsSep "\n" part.files_from}
177 OUT=$RSYNC_OUTPUT/$LOCAL
178 ${pkgs.rsync}/bin/rsync --new-compress -XAavbr --fake-super -e "ssh -o UserKnownHostsFile=/dev/null -o CheckHostIP=no -i ${ssh_key} -p $PORT" --numeric-ids --delete \
179 --backup-dir=$BAK_BASE/$LOCAL \${
180 lib.optionalString (part.args != null) "\n ${part.args} \\"}${
181 lib.optionalString (builtins.length part.exclude_from > 0) "\n --exclude-from=$EXCL_FROM \\"}${
182 lib.optionalString (builtins.length part.files_from > 0) "\n --files-from=$FILES_FROM \\"}
183 $DEST:$REMOTE . > $OUT || true
184 ### End ${profile_name} ${part_name} ###
188 options.services.rsyncBackup = {
189 mountpoint = lib.mkOption {
190 type = lib.types.path;
191 description = "Path to the base folder for backups";
193 profiles = lib.mkOption {
194 type = lib.types.attrsOf profileModule;
200 ssh_key_public = lib.mkOption {
201 type = lib.types.str;
202 description = "Public key for the backup";
204 ssh_key_private = lib.mkOption {
205 type = lib.types.str;
206 description = "Private key for the backup";
210 config = lib.mkIf (builtins.length (builtins.attrNames cfg.profiles) > 0) {
211 # FIXME: monitoring to check that backup is less than 14h old
212 users.users.backup = {
214 uid = config.ids.uids.backup;
216 extraGroups = [ "keys" ];
219 users.groups.backup = {
220 gid = config.ids.gids.backup;
223 services.cron.systemCronJobs = let
224 backup = pkgs.writeScript "backup.sh" (builtins.concatStringsSep "\n" ([
226 ] ++ lib.mapAttrsToList backup_profile cfg.profiles));
229 25 3,15 * * * backup ${backup}
233 programs.ssh.knownHosts = lib.attrsets.mapAttrs' (name: profile: lib.attrsets.nameValuePair name {
234 hostNames = [ profile.host ];
235 publicKey = "${profile.host_key_type} ${profile.host_key}";
238 system.activationScripts.rsyncBackup = {
240 text = builtins.concatStringsSep "\n" (map (v: ''
241 install -m 0700 -o backup -g backup -d ${cfg.mountpoint}/${v} ${cfg.mountpoint}/${v}/older ${cfg.mountpoint}/${v}/rsync_output
242 '') (builtins.attrNames cfg.profiles)
248 dest = "rsync_backup/identity";
251 permissions = "0400";
252 text = cfg.ssh_key_private;
255 dest = "rsync_backup/identity.pub";
258 permissions = "0444";
259 text = cfg.ssh_key_public;