1 { lib, pkgs, config, ... }:
3 domains = (lib.remove null (lib.flatten (map
7 domain = "${e.domain}${lib.optionalString (e.domain != "") "."}${zone.name}";
12 (zone.withEmail or [])
14 config.myEnv.dns.masterZones
16 mxes = lib.mapAttrsToList
17 (n: v: v.mx.subdomain)
18 (lib.attrsets.filterAttrs (n: v: v.mx.enable) config.myEnv.servers);
19 # FIXME: increase the id number in modules/private/dns.nix when this
20 # file change (date -u +'%Y%m%d%H%M%S'Z)
21 file = domain: pkgs.writeText "mta-sts-${domain.domain}.txt" (
22 builtins.concatStringsSep "\r\n" ([ "version: STSv1" "mode: testing" ]
23 ++ (map (v: "mx: ${v}.${domain.mail}") mxes)
24 ++ [ "max_age: 604800" ]
26 root = pkgs.runCommand "mta-sts_root" {} ''
28 ${builtins.concatStringsSep "\n" (map (d:
29 "cp ${file d} $out/${d.domain}.txt"
32 cfg = config.myServices.websites.tools.email;
35 config = lib.mkIf cfg.enable {
36 services.websites.webappDirs = {
40 services.websites.env.tools.vhostConfs.mta_sts = {
43 hosts = ["mta-sts.mail.immae.eu"] ++ map (v: "mta-sts.${v.domain}") domains;
44 root = "/run/current-system/webapps/_mta-sts";
48 RewriteCond %{HTTP_HOST} ^mta-sts.(.*)$
49 RewriteRule ^/.well-known/mta-sts.txt$ %{DOCUMENT_ROOT}/%1.txt [L]
50 <Directory /run/current-system/webapps/_mta-sts>