]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/websites/telio_tortay/production.nix
Migrate php sessions to redis
[perso/Immae/Config/Nix.git] / modules / private / websites / telio_tortay / production.nix
1 { lib, pkgs, config, ... }:
2 let
3 adminer = pkgs.callPackage ../commons/adminer.nix { inherit config; };
4 cfg = config.myServices.websites.telio_tortay.production;
5 varDir = "/var/lib/ftp/telio_tortay";
6 env = config.myEnv.websites.telio_tortay;
7 apacheUser = config.services.httpd.Prod.user;
8 apacheGroup = config.services.httpd.Prod.group;
9 in {
10 options.myServices.websites.telio_tortay.production.enable = lib.mkEnableOption "enable Telio Tortay's website";
11
12 config = lib.mkIf cfg.enable {
13 services.webstats.sites = [ { name = "telio-tortay.immae.eu"; } ];
14
15 security.acme.certs."ftp".extraDomainNames = [ "telio-tortay.immae.eu" ];
16
17 system.activationScripts.telio_tortay = {
18 deps = [ "httpd" ];
19 text = ''
20 install -m 0755 -o ${apacheUser} -g ${apacheGroup} -d /var/lib/ftp/telio_tortay/logs
21 '';
22 };
23 systemd.services.phpfpm-telio_tortay.after = lib.mkAfter [ "mysql.service" ];
24 systemd.services.phpfpm-telio_tortay.wants = [ "mysql.service" ];
25 services.phpfpm.pools.telio_tortay = {
26 user = apacheUser;
27 group = apacheGroup;
28 settings = {
29 "listen.owner" = apacheUser;
30 "listen.group" = apacheGroup;
31
32 "pm" = "dynamic";
33 "pm.max_children" = "20";
34 "pm.start_servers" = "2";
35 "pm.min_spare_servers" = "1";
36 "pm.max_spare_servers" = "3";
37
38 "php_admin_value[open_basedir]" = "${varDir}:/tmp";
39 "php_admin_value[session.save_handler]" = "redis";
40 "php_admin_value[session.save_path]" = "'unix:///run/redis-php-sessions/redis.sock?persistent=1&prefix=TelioTortay:Production:'";
41 };
42 phpOptions = config.services.phpfpm.phpOptions + ''
43 disable_functions = "mail"
44 '';
45 phpPackage = pkgs.php72.withExtensions({ enabled, all }: enabled ++ [all.redis]);
46 };
47 services.websites.env.production.modules = adminer.apache.modules ++ [ "proxy_fcgi" ];
48 services.websites.env.production.vhostConfs.telio_tortay = {
49 certName = "telio_tortay";
50 certMainHost = "telio-tortay.immae.eu";
51 hosts = ["telio-tortay.immae.eu" "realistesmedia.fr" "www.realistesmedia.fr" ];
52 root = varDir;
53 extraConfig = [
54 (adminer.apache.vhostConf null)
55 ''
56 Use Stats telio-tortay.immae.eu
57 ServerAdmin ${env.server_admin}
58 ErrorLog "${varDir}/logs/error_log"
59 CustomLog "${varDir}/logs/access_log" combined
60
61 <FilesMatch "\.php$">
62 SetHandler "proxy:unix:${config.services.phpfpm.pools.telio_tortay.socket}|fcgi://localhost"
63 </FilesMatch>
64
65 <Location /xmlrpc.php>
66 AllowOverride None
67 Require all denied
68 </Location>
69 <Directory ${varDir}/logs>
70 AllowOverride None
71 Require all denied
72 </Directory>
73 <Directory ${varDir}>
74 DirectoryIndex index.php index.htm index.html
75 Options Indexes FollowSymLinks MultiViews Includes
76 AllowOverride all
77 Require all granted
78 </Directory>
79 ''
80 ];
81 };
82 };
83 }