1 { lib, pkgs, config, myconfig, ... }:
3 adminer = pkgs.callPackage ../commons/adminer.nix {};
5 tellesflorian = pkgs.callPackage ./builder_app.nix {
6 inherit (pkgs.webapps) tellesflorian;
7 config = myconfig.env.websites.tellesflorian.integration;
8 apacheUser = config.services.httpd.Inte.user;
9 apacheGroup = config.services.httpd.Inte.group;
12 cfg = config.myServices.websites.florian.app;
14 options.myServices.websites.florian.app.enable = lib.mkEnableOption "enable Florian's app in integration";
16 config = lib.mkIf cfg.enable {
17 secrets.keys = tellesflorian.keys;
18 systemd.services.phpfpm-tellesflorian_dev.after = lib.mkAfter tellesflorian.phpFpm.serviceDeps;
19 systemd.services.phpfpm-tellesflorian_dev.wants = tellesflorian.phpFpm.serviceDeps;
20 systemd.services.phpfpm-tellesflorian_dev.preStart = lib.mkAfter tellesflorian.phpFpm.preStart;
21 services.phpfpm.poolConfigs.tellesflorian_dev = tellesflorian.phpFpm.pool;
22 system.activationScripts.tellesflorian_dev = tellesflorian.activationScript;
23 myServices.websites.webappDirs."${tellesflorian.apache.webappName}" = tellesflorian.app.webRoot;
24 services.websites.env.integration.modules = adminer.apache.modules ++ tellesflorian.apache.modules;
25 services.websites.env.integration.vhostConfs.tellesflorian = {
28 hosts = ["app.tellesflorian.com" ];
29 root = tellesflorian.apache.root;
31 tellesflorian.apache.vhostConf
32 adminer.apache.vhostConf
35 services.filesWatcher.phpfpm-tellesflorian_dev = {
37 paths = [ "/var/secrets/webapps/${tellesflorian.app.environment}-tellesflorian" ];