]> git.immae.eu Git - perso/Immae/Config/Nix.git/blob - modules/private/system/dilion.nix
Ateliers du changement
[perso/Immae/Config/Nix.git] / modules / private / system / dilion.nix
1 { config, pkgs, name, lib, flakes, ... }:
2 {
3 deployment = {
4 targetUser = "root";
5 targetHost = lib.head config.hostEnv.ips.main.ip4;
6 };
7 # ssh-keyscan dilion | nix-shell -p ssh-to-age --run ssh-to-age
8 secrets.ageKeys = [ "age1x49n6qa0arkdpq8530s7umgm0gqkq90exv4jep97q30rfnzknpaqate06a" ];
9 nixpkgs.system = lib.mkOverride 900 "x86_64-linux";
10 boot = {
11 loader = {
12 grub = {
13 version = 2;
14 devices = [ "/dev/sda" "/dev/sdb" "/dev/sdc" "/dev/sdd" ];
15 };
16 timeout = 1;
17 };
18 blacklistedKernelModules = [ "nvidiafb" ];
19 supportedFilesystems = [ "zfs" ];
20 kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
21 kernelModules = [ "kvm-intel" ];
22 initrd.availableKernelModules = [ "ahci" "sd_mod" ];
23 initrd.secrets = {
24 "/boot/pass.key" = "/boot/pass.key";
25 };
26 kernel.sysctl."vm.nr_hugepages" = 256; # for xmr-stak
27 # available in nixos-20.09
28 #zfs.requestEncryptionCredentials = [ "zpool/root" ];
29 };
30 powerManagement.cpuFreqGovernor = "powersave";
31 hardware.enableRedistributableFirmware = true;
32
33 myEnv = import ../../../nixops/secrets/environment.nix;
34
35 swapDevices = [ { label = "swap"; } ];
36 fileSystems = {
37 "/" = { fsType = "zfs"; device = "zpool/root"; };
38 "/boot" = { fsType = "ext4"; device = "/dev/disk/by-uuid/fd1c511e-2bc0-49d5-b8bb-95e7e8c8c816"; };
39 "/etc" = { fsType = "zfs"; device = "zpool/root/etc"; };
40 "/home" = { fsType = "zfs"; device = "zpool/root/home"; };
41 "/home/immae" = { fsType = "zfs"; device = "zpool/root/home/immae"; };
42 "/tmp" = { fsType = "zfs"; device = "zpool/root/tmp"; };
43 "/var" = { fsType = "zfs"; device = "zpool/root/var"; };
44 "/data" = { fsType = "ext4"; label = "data"; };
45 "/nix" = { fsType = "ext4"; label = "nix"; };
46 };
47
48 services.udev.extraRules = ''
49 ACTION=="add", SUBSYSTEM=="net", ATTR{address}=="10:bf:48:7f:e6:3b", NAME="eth0"
50 '';
51
52 networking = {
53 hostId = "27c3048d"; # generated with head -c4 /dev/urandom | od -A none -t x4
54 firewall.enable = false;
55 interfaces."eth0".ipv4.addresses =
56 [ { address = lib.head config.hostEnv.ips.main.ip4; prefixLength = 27; } ]
57 ++ pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
58 (n: ips: map (ip: { address = ip; prefixLength = 32; }) (ips.ip4 or []))
59 (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips));
60 interfaces."eth0".ipv6.addresses =
61 [ { address = "2a01:4f8:141:53e7::"; prefixLength = 64; } ]
62 ++ pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
63 (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
64 config.hostEnv.ips);
65 defaultGateway = { address = "176.9.10.225"; interface = "eth0"; };
66 defaultGateway6 = { address = "fe80::1"; interface = "eth0"; };
67 nameservers = [
68 "213.133.98.98"
69 "213.133.99.99"
70 "213.133.100.100"
71 "2a01:4f8:0:a0a1::add:1010"
72 "2a01:4f8:0:a102::add:9999"
73 "2a01:4f8:0:a111::add:9898"
74 ];
75 };
76
77 myServices.ssh.modules = [ config.myServices.ssh.predefinedModules.regular ];
78 imports = builtins.attrValues (import ../.. flakes) ++ [ ./dilion/vms.nix ];
79
80 system.nssModules = [ pkgs.libvirt ];
81 system.nssDatabases.hosts = lib.mkForce [ "files" "libvirt_guest" "mymachines" "dns" "myhostname" ];
82 programs.zsh.enable = true;
83
84 users.users.libvirt = {
85 hashedPassword = "!";
86 shell = pkgs.bashInteractive;
87 isSystemUser = true;
88 group = "libvirtd";
89 packages = [ pkgs.libressl.nc ];
90 openssh.authorizedKeys.keys = [
91 config.myEnv.buildbot.ssh_key.public
92 config.myEnv.sshd.rootKeys.ismael_flony
93 ];
94 };
95
96 users.groups.backup = {};
97 users.users.backup = {
98 hashedPassword = "!";
99 isSystemUser = true;
100 extraGroups = [ "keys" ];
101 group = "backup";
102 shell = pkgs.bashInteractive;
103 openssh.authorizedKeys.keys = let
104 zreplConfig = config.secrets.fullPaths."zrepl/zrepl.yml";
105 in
106 ["command=\"${pkgs.zrepl}/bin/zrepl stdinserver --config ${zreplConfig} eldiron\",restrict ${config.myEnv.zrepl_backup.ssh_key.public}"];
107 };
108 security.sudo.extraRules = pkgs.lib.mkAfter [
109 {
110 commands = [
111 { command = "/home/immae/.nix-profile/root_scripts/*"; options = [ "NOPASSWD" ]; }
112 ];
113 users = [ "immae" ];
114 runAs = "root";
115 }
116 ];
117
118 system.activationScripts.libvirtd_exports = ''
119 install -m 0755 -o root -g root -d /var/lib/caldance
120 '';
121 virtualisation.docker.enable = true;
122 virtualisation.docker.storageDriver = "zfs";
123 virtualisation.libvirtd.enable = true;
124 systemd.services.libvirtd.path = lib.mkAfter [ config.boot.zfs.package ];
125 users.groups.immae = {};
126 users.extraUsers.immae.extraGroups = [ "immae" "libvirtd" "docker" ];
127 systemd.services.libvirtd.postStart = ''
128 install -m 0770 -g libvirtd -d /var/lib/libvirt/images
129 '';
130 systemd.services.socat-caldance = {
131 description = "Forward ssh port to caldance";
132 wantedBy = [ "multi-user.target" ];
133 after = [ "network.target" ];
134
135 serviceConfig = {
136 ExecStart = "${pkgs.socat}/bin/socat TCP-LISTEN:8022,fork TCP:caldance:22";
137 };
138 };
139
140 time.timeZone = "Europe/Paris";
141 nix = {
142 settings = {
143 sandbox = "relaxed";
144 max-jobs = 8;
145 substituters = [ "https://hydra.iohk.io" "https://cache.nixos.org" ];
146 trusted-public-keys = [ "hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ=" ];
147 };
148 extraOptions = ''
149 keep-outputs = true
150 keep-derivations = true
151 allow-unsafe-native-code-during-evaluation = true
152 experimental-features = nix-command flakes
153 #Assumed in NUR
154 allow-import-from-derivation = true
155 '';
156 };
157
158 security.pki.certificateFiles = [
159 (pkgs.fetchurl {
160 url = "http://downloads.e.eriomem.net/eriomemca.pem";
161 sha256 = "1ixx4c6j3m26j8dp9a3dkvxc80v1nr5aqgmawwgs06bskasqkvvh";
162 })
163 ];
164
165 # This is equivalent to setting environment.sessionVariables.NIX_PATH
166 nix.nixPath = [
167 "home-manager=${pkgs.sources.home-manager.url}"
168 "nixpkgs=${pkgs.sources.nixpkgs-home-manager.url}"
169 ];
170
171 myServices.monitoring.enable = true;
172 myServices.certificates.enable = true;
173 security.acme.certs."${name}-immae" = config.myServices.certificates.certConfig // {
174 group = "immae";
175 domain = "dilion.immae.eu";
176 };
177 security.acme.certs."${name}" = {
178 group = config.services.nginx.group;
179 extraDomainNames = [
180 "dilion.immae.dev"
181 "caldance.cs.immae.dev"
182
183 "mobilizon.lesateliersduchangement.org"
184 ];
185 };
186 systemd.services.nginx.serviceConfig.ProtectHome = "read-only";
187 services.nginx = {
188 enable = true;
189 recommendedOptimisation = true;
190 recommendedGzipSettings = true;
191 recommendedProxySettings = true;
192 upstreams = {
193 caldance.servers."caldance:3031" = {};
194 };
195 virtualHosts = {
196 "dilion.immae.dev" = {
197 acmeRoot = config.myServices.certificates.webroot;
198 useACMEHost = name;
199 forceSSL = true;
200 locations."/".root = "/home/immae/www";
201 };
202 "caldance.cs.immae.dev" = {
203 acmeRoot = config.myServices.certificates.webroot;
204 useACMEHost = name;
205 forceSSL = true;
206 locations."/".extraConfig = ''
207 uwsgi_pass caldance;
208 '';
209 locations."/static/".alias = "/var/lib/caldance/caldance/app/www/static/";
210 locations."/media/".alias = "/var/lib/caldance/caldance/media/";
211 extraConfig = ''
212 auth_basic "Authentification requise";
213 auth_basic_user_file ${pkgs.writeText "htpasswd" config.myEnv.websites.caldance.integration.password};
214 '';
215 };
216 "mobilizon.lesateliersduchangement.org" = {
217 acmeRoot = config.myServices.certificates.webroot;
218 useACMEHost = name;
219 forceSSL = true;
220 locations."/".proxyPass = "http://localhost:19003";
221 };
222 };
223 };
224
225 systemd.services.zrepl.serviceConfig.RuntimeDirectory = lib.mkForce "zrepl zrepl/stdinserver";
226 systemd.services.zrepl.serviceConfig.User = "backup";
227 # pour eldiron:
228 # zfs allow backup create,mount,receive,destroy,rename,snapshot,hold,bookmark,release zpool/backup
229 # pour flony:
230 # zfs allow backup hold,release,bookmark,snapshot,send zpool
231 immaeServices.zrepl = {
232 enable = true;
233 config = ''
234 global:
235 control:
236 sockpath: /run/zrepl/control
237 serve:
238 stdinserver:
239 sockdir: /run/zrepl/stdinserver
240 jobs:
241 - type: sink
242 # must not change
243 name: "backup-from-eldiron"
244 root_fs: "zpool/backup"
245 serve:
246 type: tls
247 listen: :19000
248 ca: ${config.secrets.fullPaths."zrepl/certificates/eldiron.crt"}
249 cert: ${config.secrets.fullPaths."zrepl/certificates/dilion.crt"}
250 key: ${config.secrets.fullPaths."zrepl/dilion.key"}
251 client_cns:
252 - eldiron
253 - type: source
254 # must not change
255 name: "backup-to-wd-zpool"
256 # not encrypted!
257 serve:
258 type: tls
259 listen: :19001
260 ca: ${config.secrets.fullPaths."zrepl/certificates/flony.crt"}
261 cert: ${config.secrets.fullPaths."zrepl/certificates/dilion.crt"}
262 key: ${config.secrets.fullPaths."zrepl/dilion.key"}
263 client_cns:
264 - flony
265 filesystems:
266 "zpool/libvirt<": true
267 "zpool/root<": true
268 snapshotting:
269 type: manual
270 - type: source
271 # must not change
272 name: "backup-to-wd-zpool-docker"
273 # not encrypted!
274 serve:
275 type: tls
276 listen: :19002
277 ca: ${config.secrets.fullPaths."zrepl/certificates/flony.crt"}
278 cert: ${config.secrets.fullPaths."zrepl/certificates/dilion.crt"}
279 key: ${config.secrets.fullPaths."zrepl/dilion.key"}
280 client_cns:
281 - flony
282 filesystems:
283 "zpool/docker<": true
284 snapshotting:
285 type: manual
286 '';
287 };
288 # This value determines the NixOS release with which your system is
289 # to be compatible, in order to avoid breaking some software such as
290 # database servers. You should change this only after NixOS release
291 # notes say you should.
292 # https://nixos.org/nixos/manual/release-notes.html
293 system.stateVersion = "20.03"; # Did you read the comment?
294 }
295